Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1506644 - Add support for configuring 'in-overcloud' resources for octavia through workflows and ansible
Summary: Add support for configuring 'in-overcloud' resources for octavia through work...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Carlos Goncalves
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
: 1515162 1560541 (view as bug list)
Depends On: 1506641
Blocks: 1433523 1433537 1488801 1506643
TreeView+ depends on / blocked
 
Reported: 2017-10-26 13:39 UTC by Brent Eagles
Modified: 2018-06-27 13:39 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-common-8.6.1-0.20180410165747.4d8ca16.el7ost openstack-tripleo-heat-templates-8.0.2-0.20180410170330.a39634a.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1506641
Environment:
Last Closed: 2018-06-27 13:38:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:39:58 UTC
OpenStack gerrit 487450 None master: MERGED tripleo-common: Add ansible playbook for configuring octavia (Ia4916e431bf241b92194773a4d55300c7230ebf9) 2018-04-13 20:19:43 UTC
OpenStack gerrit 515402 None master: MERGED tripleo-common: Octavia post deployment mistral wrapper (If07ded033be9f44b7c7a7e09214032fa89a02e77) 2018-04-13 20:19:36 UTC
OpenStack gerrit 557483 None master: MERGED tripleo-common: Move health_manager cfg section to octavia_worker (I27de3a2eec82a7bd99b72744023f29af5ea323c0) 2018-04-13 20:19:30 UTC
OpenStack gerrit 557731 None master: MERGED tripleo-heat-templates: Add firewall rule to octavia health mgmt iface (If6c98c18dfe02d5ab8af1806fed401ab945ed18a) 2018-04-13 20:19:23 UTC
OpenStack gerrit 557918 None stable/queens: MERGED tripleo-common: Move health_manager cfg section to octavia_worker (I27de3a2eec82a7bd99b72744023f29af5ea323c0) 2018-04-13 20:19:17 UTC
OpenStack gerrit 559166 None stable/queens: MERGED tripleo-heat-templates: Add firewall rule to octavia health mgmt iface (If6c98c18dfe02d5ab8af1806fed401ab945ed18a) 2018-04-13 20:19:11 UTC
Red Hat Bugzilla 1560541 None CLOSED LB operation status is offline but LB works 2019-02-21 20:07:10 UTC

Internal Links: 1560541

Description Brent Eagles 2017-10-26 13:39:09 UTC
+++ This bug was initially created as a clone of Bug #1506641 +++

Complete configuration of Octavia requires the creation of resources in the overcloud. This requires host configuration steps and openstack cloud operations on the overcloud glance, neutron and nova services. Running ansible from a mistral workflow seems to be a workable solution as it has the required integration with heat and allows host level commands to be run in a deterministic intuitive manner.

Comment 6 Nir Magnezi 2017-12-06 13:29:49 UTC
A note for when we verify this: double-check the config options mentioned in bug 1515162 comment 0

Comment 7 Nir Magnezi 2017-12-06 13:30:33 UTC
*** Bug 1515162 has been marked as a duplicate of this bug. ***

Comment 16 Carlos Goncalves 2018-03-28 19:09:51 UTC
The [health_manager]/controller_ip_port_list is being set but in a config file that is being consumed by the octavia-health-manager service. Instead, it should be set in the config file of the octavia-worker service. Patch https://review.openstack.org/#/c/557483/ should address this bug.

Comment 17 Carlos Goncalves 2018-03-29 15:09:41 UTC
One other issue found after applying patch https://review.openstack.org/#/c/557483/ was that the firewall was dropping the heartbeats sent to the health manager. Patch submitted upstream to add firewall rule: https://review.openstack.org/#/c/557731/

Comment 21 Carlos Goncalves 2018-04-05 20:33:35 UTC
Patches proposed to stable/queens. Moving to POST.

Comment 25 Bernard Cafarelli 2018-04-16 15:07:27 UTC
*** Bug 1560541 has been marked as a duplicate of this bug. ***

Comment 27 Alexander Stafeyev 2018-04-22 09:13:01 UTC
Verified with https://bugzilla.redhat.com/show_bug.cgi?id=1560541 steps. 


(tester) [stack@undercloud-0 ~]$ openstack loadbalancer show fd9ff774-1c33-447f-8f4a-2bb8de03083c
+---------------------+--------------------------------------+
| Field               | Value                                |
+---------------------+--------------------------------------+
| admin_state_up      | True                                 |
| created_at          | 2018-04-22T08:58:40                  |
| description         |                                      |
| flavor              |                                      |
| id                  | fd9ff774-1c33-447f-8f4a-2bb8de03083c |
| listeners           |                                      |
| name                | lb1                                  |
| operating_status    | ONLINE                               |
| pools               |                                      |
| project_id          | 516a990ff19046ac85bad8807b62087b     |
| provider            | octavia                              |
| provisioning_status | ACTIVE                               |
| updated_at          | 2018-04-22T08:59:56                  |
| vip_address         | 192.168.2.9                          |
| vip_network_id      | 6caf6750-68ac-4e84-9715-5e38f3e3953e |
| vip_port_id         | c102d79b-3e1c-4951-8797-80a198ec678b |
| vip_qos_policy_id   | None                                 |
| vip_subnet_id       | 15fe1d40-517b-4318-acc9-4b123e7cee08 |
+---------------------+--------------------------------------+

Comment 30 errata-xmlrpc 2018-06-27 13:38:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.