Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1506049 - [RFE] Chargeback rates should support different currencies - NZD,AUD
Summary: [RFE] Chargeback rates should support different currencies - NZD,AUD
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-24 23:08 UTC by tachoi
Modified: 2018-07-17 14:14 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-17 14:14:42 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2533351 None None None 2018-06-01 07:06:34 UTC

Description tachoi 2017-10-24 23:08:22 UTC
Description of problem:
Rates in chargeback does not have any unit associated, a rate should include a unit: for instance: €/month, €cent/month, $/month, now it is /month, that is not a rate.

Version-Release number of selected component (if applicable):
5.8.x

How reproducible:
Always there

Steps to Reproduce:
1. Go to chargeback rates
2.
3.

Actual results:
There is the possibility to choose "per time", and "per unit", but there is no way to choose "per currency". In a multinational company, that would mean that you can't differentiate rates in different countries.


Expected results:
A user should be able to choose currency, and create new ones with or without relationship to others.
Currencies should be dynamic, being possible to change a currency in one date (i.e. a currency is applied until the country joins the Eurozone and the € is applied). This could also be configured as a currency that can be applied only in a specific time.

Additional info:

Comment 4 Chris Kacerguis 2017-11-15 20:46:05 UTC
*** Bug 1513718 has been marked as a duplicate of this bug. ***

Comment 7 Gregg Tanzillo 2018-06-01 13:19:03 UTC
This change was made in master and will be included in the next release which is "Hammer"

This is the PR - https://github.com/ManageIQ/manageiq/pull/17456


Note You need to log in before you can comment on or make changes to this bug.