Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1504777 - Bookmarks are not sorted after upgrade
Summary: Bookmarks are not sorted after upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ravi Nori
QA Contact: samuel macko
URL:
Whiteboard:
Depends On:
Blocks: 1511335
TreeView+ depends on / blocked
 
Reported: 2017-10-20 15:19 UTC by Jaroslav Spanko
Modified: 2018-05-15 17:46 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1511335 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:45:44 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 None None None 2018-05-15 17:46:48 UTC

Description Jaroslav Spanko 2017-10-20 15:19:17 UTC
Description of problem:
After upgrade from 4.1.5 to 4.1.6.2 the bookmarks are not sorted

Version-Release number of selected component (if applicable):
4.1.6.2

How reproducible:
100%

Steps to Reproduce:
1. Create bookmarks 
2. Bookmarks are not sorted in 4.1.6.2 by name but random added to the list


Actual results:
Bookmarks are random added to the list

Expected results:
Sorted bookmarks as in previous 4.1.5

Additional info:
The screenshots attached

Comment 5 Martin Perina 2017-11-09 07:50:16 UTC
In 4.2 this was most probably fixed as a part of UI changes, for 4.1.z we need a fix tracked by BZ1511335

Comment 6 Jaroslav Spanko 2017-11-09 15:08:10 UTC
Hi Martin, yes in 4.2 sorting works.
Thx

Comment 7 RHV Bugzilla Automation and Verification Bot 2017-12-06 15:52:07 UTC
I don't see any attached patches to this bug, how should we know which version of engine it was fixed on? the bot won't move it to ON_QA in this status.

Comment 8 RHV Bugzilla Automation and Verification Bot 2017-12-06 16:14:16 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 9 RHV Bugzilla Automation and Verification Bot 2017-12-06 16:50:31 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No relevant external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 11 Martin Perina 2017-12-06 19:15:36 UTC
Added manually to errata and adding a TestOnly keyword as sorting has already been fixed in 4.2 during UI redesign

Comment 12 samuel macko 2018-01-22 15:14:24 UTC
Verified in ovirt version 4.2.1.2-0.1.el7.

Verified by following the reproducer.

Comment 16 errata-xmlrpc 2018-05-15 17:45:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488


Note You need to log in before you can comment on or make changes to this bug.