Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 150382 - net.agent does not handle removal of wireless card
Summary: net.agent does not handle removal of wireless card
Keywords:
Status: CLOSED DUPLICATE of bug 127283
Alias: None
Product: Fedora
Classification: Fedora
Component: hotplug
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-05 08:58 UTC by Richard Levitt
Modified: 2014-03-17 02:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:08:15 UTC


Attachments (Terms of Use)

Description Richard Levitt 2005-03-05 08:58:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Upon removal of wireless card (Netgear WG511), net-agent fails to
handle event:

/var/log/messages:

Mar  5 08:09:11 localhost net.agent[5449]: remove event not handled
Mar  5 08:09:12 localhost net.agent[5446]: remove event not handled

As a result, ifdown eth1 is not run when the card is removed.  This
means that the dhclient is not killed.  If the card is reinserted,
there will be two dhclients running, and no IP address will be allocated.

As a brute force fix, I have added "ifdown eth1" to the top of my
/etc/hotplug/net.agent.  It's not elegant, but it works.

In case it's relevant, I have added "alias eth1 islpci_cb" to
/etc/modprobe.conf (as described in some advice somewhere on the
Internet) to get this card recognised by system-config-network. 
Subject to that, the card has been added to the system via
system-config-network in a standard way.

RANT ONE:

This Bug was previously reported as 127283 for FC2 in July 2004.  That
Bug report contains further history.  Comment 3 says "A call to ifdown
added in 2004_09_23-1. Note that this may very well
not do anything useful without modifying ifdown."  In fact, a call to
ifdown eth1 is exactly what is needed, but net.agent is not making
that call.

RANT TWO:

Why is the (massively popular) WG511 wireless card (and, I imagine,
any other prism54 card) so poorly supported in every version of FC?

A popup should tell the poor user that firmware needs to be downloaded
to get the card to work.  Isn't that the minimum any half decent
operating system would do?  It's not as if the relevant developers are
unaware of this issue.

Having worked out that firmware must be obtained, why is the poor user
left to amend /etc/modprobe.conf manually in order to get this card
recognised by system-config-network?

In the end, the steps required to get the card to work perfectly well
are trivial (get firmware; add a line to /etc/modprobe.conf; run
system-config-network to add card; brute force fix
/etc/hotplug/net.agent), but the amount of time and effort taken to
figure all of this out is significant and I guess a large percentage
of would be users just give up and return to XP.

Version-Release number of selected component (if applicable):
hotplug-2004_04_01-8.1

How reproducible:
Always

Steps to Reproduce:
1.Insert wireless network card.
2.Remove it

    

Actual Results:  /var/log/messages:

Mar  5 08:09:11 localhost net.agent[5449]: remove event not handled
Mar  5 08:09:12 localhost net.agent[5446]: remove event not handled

Expected Results:  net.agent should have run ifdown eth1

Additional info:

Comment 1 Bill Nottingham 2005-03-07 17:55:18 UTC

*** This bug has been marked as a duplicate of 127283 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:08:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.