Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 150346 - clustat is riddled with usability problems
Summary: clustat is riddled with usability problems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
: 158611 (view as bug list)
Depends On: 157098
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-04 19:27 UTC by Lon Hohberger
Modified: 2009-04-16 20:16 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-821
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-28 20:01:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:821 normal SHIPPED_LIVE rgmanager bug fix update 2005-10-28 04:00:00 UTC

Description Lon Hohberger 2005-03-04 19:27:32 UTC
Description of problem:

The output of clustat when the node is or isn't running rgmanager is
completely different.  Also, the output is completely bogus when
running GuLM -- it reports all nodes as members of any given group.

This is partly a magma-ism:  Magma reports that all nodes are members
of all requested groups irrespective of the infrastructure's support
of "node groups" or "service groups".

Comment 1 Lon Hohberger 2005-03-07 17:24:37 UTC
Furthermore, there isn't enough space for all the service states in
the service state column.

recovering works, but "uninitialized", etc. don't.

e.g.:

uninitiali
recoverabl


Comment 2 Lon Hohberger 2005-05-06 20:35:26 UTC
... And "resource groups" aren't the right name, they're "Services"

Comment 3 Lon Hohberger 2005-05-23 23:18:37 UTC
*** Bug 158611 has been marked as a duplicate of this bug. ***

Comment 4 Lon Hohberger 2005-05-24 20:53:04 UTC
Considering changing (as an example) to the following output format for clustat.
 This would require a rewrite; as it would require CCS information which is
currently not needed.

Node flags:

R = "running rgmanager" - member of the rgmanager service group (cman only)
L = "local node": replaces the "<--- You are here" indicator
M = Missing from ccs configuration!

Service flags:

N = "No-autostart" Autostart disabled (service starts automatically when cluster
is quorate)
X = Exclusive service


Output when running on a node running rgmanager (example only):

  Member Name                              State      Flags
  ------ ----                              -----      -----
  red                                      Online     RL
  green                                    Online     R
  blue                                     Offline
  cyan                                     Online     M
  magenta                                  Online     R

  Service Name         Owner (Last)        State      Flags     
  ------- ----         ----- ------        -----      -----
  nfsservice           red                 started    
  redonly              red                 started   
  greenonly            (none)              stopped    N
  nostart              (none)              stopped    NX
  exclusive            (none)              stopped    X
  greenpref            red                 started  


Output on a node not running rgmanager:

Not running rgmanager.  Service state information unavailable.

  Member Name                              State      Flags
  ------ ----                              -----      -----
  red                                      Online     L
  green                                    Online     
  blue                                     Offline
  cyan                                     Online     M
  magenta                                  Online


Comment 5 Lon Hohberger 2005-10-17 20:34:37 UTC
Fix in CVS.

Comment 7 Red Hat Bugzilla 2005-10-28 20:01:34 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-821.html



Note You need to log in before you can comment on or make changes to this bug.