Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 150297 - missing expression in return statement
Summary: missing expression in return statement
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex-lgrind
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 162523 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-04 14:28 UTC by David Binderman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-23 19:45:03 UTC


Attachments (Terms of Use)

Description David Binderman 2005-03-04 14:28:24 UTC
Description of problem:

I just tried to compile tetex-lgrind-3.67-4 from 
Redhat Fedora Extras development tree with the Intel C compiler.

The Intel compiler said

lgutil.c(280): warning #117: non-void function "parsevartab" should
return a value

The source code is

varsubst *parsevartab(char* fname)
{
        FILE *f = fopen(fname, "rt");
        char linebuf[201], *cp;
        varsubst *varsubsts=NULL, *substitem, *substlistpos;

        if (f==NULL) return;

Suggest add expression into return statement.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michael Schwendt 2005-07-23 19:45:03 UTC
Will be fixed in tetex-lgrind-3.67-7

Comment 2 Michael Schwendt 2005-07-23 19:55:03 UTC
*** Bug 162523 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.