Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1501265 - [Regression] Unexpected error encountered after clicking on VMware vms PoweredOff rss link
Summary: [Regression] Unexpected error encountered after clicking on VMware vms Powere...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Gregg Tanzillo
QA Contact: Niyaz Akhtar Ansari
URL:
Whiteboard:
: 1466439 (view as bug list)
Depends On:
Blocks: 1517826 1542577
TreeView+ depends on / blocked
 
Reported: 2017-10-12 09:57 UTC by Niyaz Akhtar Ansari
Modified: 2018-06-21 20:50 UTC (History)
8 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1517826 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:50:13 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
rss (deleted)
2017-10-12 09:57 UTC, Niyaz Akhtar Ansari
no flags Details

Description Niyaz Akhtar Ansari 2017-10-12 09:57:04 UTC
Created attachment 1337657 [details]
rss

Description of problem:


Version-Release number of selected component (if applicable):
Version 5.9.0.2.20171010190026_0413a06 

How reproducible:
100%

Steps to Reproduce:
1.Go to cloud Intel->RSS 
2.Click on VMware VMs PoweredOff rss link


Actual results:


Expected results:


Additional info:

Production log:

[----] I, [2017-10-12T05:56:03.010327 #13094:18e5e08]  INFO -- : Started GET "/alert/rss?feed=vmpoweroff" for 127.0.0.1 at 2017-10-12 05:56:03 -0400
[----] I, [2017-10-12T05:56:03.013972 #13094:18e5e08]  INFO -- : Processing by AlertController#rss as HTML
[----] I, [2017-10-12T05:56:03.014066 #13094:18e5e08]  INFO -- :   Parameters: {"feed"=>"vmpoweroff"}
[----] F, [2017-10-12T05:56:03.034933 #13094:18e5e08] FATAL -- : Error caught: [ActiveRecord::StatementInvalid] PG::UndefinedColumn: ERROR:  column event_streams.created_on :desc does not exist
LINE 1: ...) AND (event_type = 'VmPoweredOffEvent') ORDER BY "event_str...
                                                             ^
: SELECT  "event_streams".* FROM "event_streams" WHERE "event_streams"."type" IN ('EmsEvent') AND (event_type = 'VmPoweredOffEvent') ORDER BY "event_streams"."created_on :desc" ASC LIMIT $1
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/postgresql_adapter.rb:598:in `async_exec'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/postgresql_adapter.rb:598:in `block in exec_no_cache'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/abstract_adapter.rb:590:in `block in log'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/notifications/instrumenter.rb:21:in `instrument'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/abstract_adapter.rb:583:in `log'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/postgresql_adapter.rb:598:in `exec_no_cache'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/postgresql_adapter.rb:587:in `execute_and_clear'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/postgresql/database_statements.rb:103:in `exec_query'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/abstract/database_statements.rb:373:in `select'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/abstract/database_statements.rb:41:in `select_all'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/abstract/query_cache.rb:93:in `block in select_all'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/abstract/query_cache.rb:108:in `cache_sql'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/connection_adapters/abstract/query_cache.rb:93:in `select_all'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/querying.rb:39:in `find_by_sql'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/relation.rb:706:in `exec_queries'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/relation.rb:583:in `load'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/relation.rb:260:in `records'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/relation.rb:256:in `to_a'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/relation/finder_methods.rb:563:in `find_nth_with_limit'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/relation/finder_methods.rb:592:in `find_nth_with_limit_and_offset'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/relation/finder_methods.rb:545:in `find_nth'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/relation/finder_methods.rb:122:in `first'
/var/www/miq/vmdb/lib/resource_feeder/lib/resource_feeder/rss.rb:20:in `rss_feed_for'
/var/www/miq/vmdb/app/models/rss_feed.rb:46:in `generate'
/opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-76625529fb02/app/controllers/alert_controller.rb:48:in `rss'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/basic_implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/abstract_controller/base.rb:188:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/rendering.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:126:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:506:in `block (2 levels) in compile'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:455:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:101:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:750:in `_run_process_action_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:90:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/abstract_controller/callbacks.rb:19:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/rescue.rb:20:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/instrumentation.rb:32:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/notifications/instrumenter.rb:21:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/instrumentation.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal/params_wrapper.rb:248:in `process_action'
/opt/rh/cfme-gemset/gems/activerecord-5.0.6/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/abstract_controller/base.rb:126:in `process'
/opt/rh/cfme-gemset/gems/actionview-5.0.6/lib/action_view/rendering.rb:30:in `process'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal.rb:190:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_controller/metal.rb:262:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/routing/route_set.rb:50:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/routing/route_set.rb:32:in `serve'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/journey/router.rb:39:in `block in serve'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/journey/router.rb:26:in `each'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/journey/router.rb:26:in `serve'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/routing/route_set.rb:727:in `call'
/opt/rh/cfme-gemset/gems/secure_headers-3.0.3/lib/secure_headers/middleware.rb:10:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/etag.rb:25:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/conditional_get.rb:25:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/head.rb:12:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/session/abstract/id.rb:232:in `context'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/session/abstract/id.rb:226:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/cookies.rb:613:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/callbacks.rb:38:in `block in call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:97:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:750:in `_run_call_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/callbacks.rb:90:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/callbacks.rb:36:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/remote_ip.rb:79:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/debug_exceptions.rb:49:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/show_exceptions.rb:31:in `call'
/opt/rh/cfme-gemset/gems/railties-5.0.6/lib/rails/rack/logger.rb:36:in `call_app'
/opt/rh/cfme-gemset/gems/railties-5.0.6/lib/rails/rack/logger.rb:26:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/request_id.rb:24:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/method_override.rb:22:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/runtime.rb:22:in `call'
/opt/rh/cfme-gemset/gems/activesupport-5.0.6/lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
/opt/rh/cfme-gemset/gems/actionpack-5.0.6/lib/action_dispatch/middleware/executor.rb:12:in `call'
/opt/rh/cfme-gemset/gems/rack-2.0.3/lib/rack/sendfile.rb:111:in `call'
/opt/rh/cfme-gemset/gems/railties-5.0.6/lib/rails/engine.rb:522:in `call'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/configuration.rb:232:in `call'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/server.rb:578:in `handle_request'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/server.rb:415:in `process_client'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/server.rb:275:in `block in run'
/opt/rh/rh-ruby23/root/usr/share/gems/gems/puma-3.7.1/lib/puma/thread_pool.rb:120:in `block in spawn_thread'
[----] I, [2017-10-12T05:56:03.035914 #13094:18e5e08]  INFO -- :   Rendering /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-76625529fb02/app/views/layouts/exception.html.haml within layouts/application
[----] I, [2017-10-12T05:56:03.036458 #13094:18e5e08]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-76625529fb02/app/views/layouts/_exception_contents.html.haml (0.2ms)
[----] I, [2017-10-12T05:56:03.036561 #13094:18e5e08]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-76625529fb02/app/views/layouts/exception.html.haml within layouts/application (0.5ms)
[----] I, [2017-10-12T05:56:03.036821 #13094:18e5e08]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/gems/manageiq-ui-classic-76625529fb02/app/views/layouts/_doctype.html.haml (0.0ms)
[----] I, [2017-10-12T05:56:03.038228 #13094:18e5e08]  INFO -- :   Rendered /opt/rh/cfme-gemset/bundler/

Comment 4 CFME Bot 2017-11-22 20:06:41 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/9b399363eb83e0518eb00b41293ba705eeb194b3

commit 9b399363eb83e0518eb00b41293ba705eeb194b3
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Fri Nov 17 10:45:16 2017 -0500
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Fri Nov 17 10:45:16 2017 -0500

    Fixed syntax with `orderby` in RSS Feed YAML files
    
    The issue was causing the orderby column and direction to be pulled in as a single symbol in stead of a hash
    causing a SQL error while generating the feed.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1501265

 product/alerts/rss/vmpowerevent.yml | 2 +-
 product/alerts/rss/vmpoweroff.yml   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comment 9 Tim Wade 2018-03-20 15:04:39 UTC
*** Bug 1466439 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.