Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1500833 - Dialog name is empty in editing screen of Ansible Playbook catalog item
Summary: Dialog name is empty in editing screen of Ansible Playbook catalog item
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: All
OS: All
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Harpreet Kataria
QA Contact: Dmitry Misharov
URL:
Whiteboard: ansible:service:ui
: 1501528 1512795 (view as bug list)
Depends On:
Blocks: 1438923 1511508
TreeView+ depends on / blocked
 
Reported: 2017-10-11 14:57 UTC by Dmitry Misharov
Modified: 2018-06-21 20:33 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1511508 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:33:21 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Dmitry Misharov 2017-10-11 14:57:07 UTC
Description of problem:


Version-Release number of selected component (if applicable):
5.9.0.1.20171004215954_13427ce

How reproducible:
Always

Steps to Reproduce:
1. Create Ansible Playbook.
2. Open editing screen of the item.

Actual results:
Dialog field is empty.

Expected results:
Dialog field should be filled as it was created before.

Comment 5 CFME Bot 2017-11-08 22:04:58 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/e92071a526792dd0eb48868126a2375866b2e13a

commit e92071a526792dd0eb48868126a2375866b2e13a
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Nov 8 16:08:51 2017 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Nov 8 16:10:46 2017 -0500

    Fixed to initialize Dialog drop down correctly.
    
    Added check in jasmine spec test to verify JS controller sets value correctly, and fixed existing checks to check against value that is being set in JS controller instead of mock value.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1500833

 .../javascripts/controllers/catalog/catalog_item_form_controller.js  | 3 +--
 .../controllers/catalog/catalog_item_form_controller_spec.js         | 5 +++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comment 7 Harpreet Kataria 2017-11-10 14:48:43 UTC
*** Bug 1511882 has been marked as a duplicate of this bug. ***

Comment 8 Harpreet Kataria 2017-11-14 16:42:08 UTC
*** Bug 1512795 has been marked as a duplicate of this bug. ***

Comment 10 Harpreet Kataria 2018-05-03 18:50:54 UTC
*** Bug 1501528 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.