Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1498975 - [abrt] Race condition at gdbusnamewatching.c:on_connection_disconnected()
Summary: [abrt] Race condition at gdbusnamewatching.c:on_connection_disconnected()
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glib2
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Colin Walters
QA Contact: Desktop QE
URL:
Whiteboard:
: 1439080 1483454 1509875 1554269 (view as bug list)
Depends On: 1437669
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-05 17:02 UTC by Milan Crha
Modified: 2018-06-18 11:50 UTC (History)
8 users (show)

Fixed In Version: glib2-2.54.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1437669
Environment:
Last Closed: 2018-06-18 11:50:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 777307 None None None 2017-10-18 16:57:11 UTC

Description Milan Crha 2017-10-05 17:02:14 UTC
+++ This bug was initially created as a clone of Bug #1437669 +++

Vlada has still some similar crashes, even with glib2 which has the changes included, the same as too many crashes related to this glib2 function had been reported for Fedora 26, most of them gathered under bug #1483205, which also contains a proposed patch, which is awaiting review.

Comment 2 Milan Crha 2017-10-09 08:23:09 UTC
I forgot to mention my steps:
a) log in to the GNOME Shell
b) start Evolution in the Mail view
c) wait until it has finished the initial mail update
d) stop Evolution
e) log out
f) repeat from step a)

Once the issue strikes, the ABRT will claim a new problem at step a) coming either from evolution-calendar-factory-subprocess or from evolution-addressbook-factory-subprocess. I've got crashes from both.

I had configured several calendars and also had set my On This Computer/Personal address book to be included in the Birthdays & Anniversaries calendar, which is included for reminders in Edit->Preferences->Calendar and Tasks->Reminders tab.

Comment 3 Milan Crha 2017-10-09 08:23:35 UTC
*** Bug 1483454 has been marked as a duplicate of this bug. ***

Comment 5 Milan Crha 2017-10-18 16:53:26 UTC
I found out that glib2 2.54.0 has a change from [1]. I forgot of it long time ago.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=777307

Comment 6 Milan Crha 2017-11-06 10:38:47 UTC
*** Bug 1509875 has been marked as a duplicate of this bug. ***

Comment 7 Kalev Lember 2018-03-15 10:07:54 UTC
Sorry Milan, I totally missed that bug back then! 

I think we can close this now as we have glib2-2.54.2-2.el7 in 7.5 which includes the upstream fix (https://gitlab.gnome.org/GNOME/glib/commit/4dd1b17)

Comment 8 Milan Crha 2018-03-15 11:21:45 UTC
Right, that's the original bug #1437669, from which I made this clone. The thing is that there are still some automated tests failing in the on_connection_disconnected(), but there's a mess around it, because it's unsure (or I'm highly unsure) whether it's only on machines which didn't update to RHEL 7.5 yet, or also on machines with the proper glib2 installed.

Could you, QA folks, verify the content of the machines which claim the error (and fill/pair with old FAF reports), please?

Comment 9 Milan Crha 2018-06-05 11:14:14 UTC
*** Bug 1439080 has been marked as a duplicate of this bug. ***

Comment 10 Milan Crha 2018-06-05 11:23:59 UTC
*** Bug 1554269 has been marked as a duplicate of this bug. ***

Comment 11 Vladimir Benes 2018-06-18 11:50:45 UTC
Will reopen if we see this again, seems to be a bit stalled and rebase to 3.28 should solve it.


Note You need to log in before you can comment on or make changes to this bug.