Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 149775 - Can't understand DeviceURI: hp:
Summary: Can't understand DeviceURI: hp:
Keywords:
Status: CLOSED DUPLICATE of bug 143901
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-printer
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-26 13:05 UTC by Christian Pearce
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-06 12:08:55 UTC


Attachments (Terms of Use)

Description Christian Pearce 2005-02-26 13:05:21 UTC
Description of problem:

I have a printer based on the hplip package.  It is an HP package that
adds proper dirvers for all their USB printers.

Run:

[lael@insight lael]$ printtool
Can't understand DeviceURI: hp:/usb/PSC_2350_series?serial=MY48BC42ZYKJ

I am sure by what it is erroring out on you can figure out what is
going on in code.

Looks like _discover_queue in /usr/share/printconf/util/cups_import.py
doesn't have a section for "hp".

Comment 1 Tim Waugh 2005-04-06 12:08:55 UTC
It isn't an error -- that device has been ignored.  system-config-printer
doesn't yet have support for hplip, and so it can't represent hplip queues in
its configuration.


*** This bug has been marked as a duplicate of 143901 ***


Note You need to log in before you can comment on or make changes to this bug.