Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1497684 - Server role: Cockpit not taken into count
Summary: Server role: Cockpit not taken into count
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.9.0
Assignee: Brian McLaughlin
QA Contact: Vatsal Parekh
URL:
Whiteboard:
: 1469966 (view as bug list)
Depends On:
Blocks: 1512754
TreeView+ depends on / blocked
 
Reported: 2017-10-02 13:05 UTC by Vatsal Parekh
Modified: 2018-03-06 14:45 UTC (History)
5 users (show)

Fixed In Version: 5.9.0.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1512754 (view as bug list)
Environment:
Last Closed: 2018-03-06 14:45:37 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Vatsal Parekh 2017-10-02 13:05:45 UTC
Description of problem:
The server role of Cockpit under Configuration has not taken into count, even if its not enabled, 'Web Console' is still accessible for VMs

Version-Release number of selected component (if applicable):
Version master.20171002075455_8547972
also seeing this in 5.9 nightly build we got

How reproducible:
100%

Steps to Reproduce:
1. Don't enable Cockpit Server role in configuration
2. Compute->Infra->Virtual Machine
3. 'Access'->'Web Console'

Actual results:
Web console option showed and working even if server role is disabled

Expected results:
Should require to first enable the Server role

Additional info:

Comment 4 CFME Bot 2017-10-05 21:58:32 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/a6e0e68a8918704a40455727865c899528820c14

commit a6e0e68a8918704a40455727865c899528820c14
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Tue Oct 3 15:56:12 2017 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Thu Oct 5 16:51:02 2017 -0400

    Check for cockpit_ws server role to enable Web Console button
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1497684

 .../application_helper/button/cockpit_console.rb   |  6 +-
 .../buttons/cockpit_console_spec.rb                | 68 ++++++++++++++++------
 2 files changed, 53 insertions(+), 21 deletions(-)

Comment 5 CFME Bot 2017-10-05 21:58:36 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/a48b91d77ff1f5d21dee46b5fec16236f3303c18

commit a48b91d77ff1f5d21dee46b5fec16236f3303c18
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Wed Oct 4 13:50:52 2017 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Thu Oct 5 16:51:45 2017 -0400

    Seed MiqRegion to support checking for web console role
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1497684

 spec/controllers/container_node_controller_spec.rb | 1 +
 spec/controllers/vm_cloud_controller/trees_spec.rb | 1 +
 spec/controllers/vm_infra_controller/trees_spec.rb | 1 +
 spec/controllers/vm_infra_controller_spec.rb       | 1 +
 4 files changed, 4 insertions(+)

Comment 6 Vatsal Parekh 2017-11-01 12:08:48 UTC
Able to verify this on 5.9.0.4

Comment 7 Satoe Imaishi 2017-11-14 01:20:45 UTC
*** Bug 1469966 has been marked as a duplicate of this bug. ***

Comment 9 Brian McLaughlin 2017-11-16 13:02:34 UTC
*** Bug 1469966 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.