Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1494178 - dnf system-upgrade: dnf.exceptions.RepoError: Failed to synchronize cache for repo 'updates-testing'
Summary: dnf system-upgrade: dnf.exceptions.RepoError: Failed to synchronize cache for...
Keywords:
Status: CLOSED DUPLICATE of bug 1492036
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-21 15:24 UTC by Satish Balay
Modified: 2017-09-21 18:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-21 18:01:56 UTC


Attachments (Terms of Use)
/var/log/dnf.log (deleted)
2017-09-21 15:24 UTC, Satish Balay
no flags Details

Description Satish Balay 2017-09-21 15:24:02 UTC
Created attachment 1329049 [details]
/var/log/dnf.log

Description of problem:

Upgrading to F27 from F26 using 'dnf system upgrade' gives an error on rebooting with 'dnf system-upgrade reboot'

Version-Release number of selected component (if applicable):

DNF version: 2.6.3

How reproducible:

Once

Steps to Reproduce:
1. Start with F26
2. enable updates-testing repo
3. dnf system-upgrade download --enablerepo=updates-testing --releasever=27
4. dnf system-upgrade reboot

Actual results:

system upgrade to f27 fails - and then reboots back to F26

Expected results:

system upgrade to f27 should complete without error

Additional info:

librepo.LibrepoException: (8, "Cannot prepare internal mirrorlist: Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=updates-testing-f27&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]", 'An Curl handle error')


It appears that 'dnf' is doing a network check for the repo data during this stage - and perhaps the network was not up by that time - so it aborted.

Shouldn't dnf do a 'yum localupdate' equivalent operation at this stage - and not rely on the network?

Also this metadata sync operation [if there is anything new to download] invalidates any of the checks 'dnf system-upgrade download' did - prior to 'dnf system-upgrade reboot'


Subsequent 'dnf system-upgrade reboot' got the upgrade to F27 going without this error

Comment 1 Satish Balay 2017-09-21 15:42:48 UTC
(In reply to Satish Balay from comment #0)

> 3. dnf system-upgrade download --enablerepo=updates-testing --releasever=27

Sorry - should have said 'dnf system-upgrade download --releasever=27' 

the updates-testing repo was enabled manually due to #1490832

From dnf.log

2017-09-20T23:52:54Z DDEBUG Command: dnf --releasever=27 system-upgrade upgrade

Comment 2 Satish Balay 2017-09-21 18:01:56 UTC

*** This bug has been marked as a duplicate of bug 1492036 ***


Note You need to log in before you can comment on or make changes to this bug.