Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1492585 - [RFE] Add --brief and --quiet parameters to katello-service status
Summary: [RFE] Add --brief and --quiet parameters to katello-service status
Keywords:
Status: CLOSED DUPLICATE of bug 1366691
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Usability
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-18 09:03 UTC by Luc de Louw
Modified: 2017-09-20 19:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-20 19:20:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Luc de Louw 2017-09-18 09:03:37 UTC
Description of problem:

When running "katello-service status", one gets flooded by information in the output, usually one would just like to know if a service is in status running or failed w/o the additional output.

It would be great to add a parameter --brief which omits the additional output

A parameter --quiet which returns nothing than an exit code (0=all fine, non-0=something is wrong would be handy for simple monitoring purposes.

Version-Release number of selected component (if applicable):
katello-service-3.0.0-20

How reproducible:
Always

Steps to Reproduce:
1. Run katello-service status
2. Search for "failed" or similar in the output
3. Getting confused and miss the important information

Actual results:


Expected results:


Additional info:

Comment 2 Brad Buckingham 2017-09-20 19:20:04 UTC

*** This bug has been marked as a duplicate of bug 1366691 ***


Note You need to log in before you can comment on or make changes to this bug.