Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1492544 - Set openshift_prometheus_state=absent, it installed prometheus again instead of undeploy prometheus
Summary: Set openshift_prometheus_state=absent, it installed prometheus again instead ...
Keywords:
Status: CLOSED DUPLICATE of bug 1508310
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.7.0
Assignee: Zohar Gal-Or
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-18 06:20 UTC by Junqi Zhao
Modified: 2017-11-22 08:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-22 08:54:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible running log, intent to undeploy prometheus (deleted)
2017-09-18 06:20 UTC, Junqi Zhao
no flags Details

Description Junqi Zhao 2017-09-18 06:20:00 UTC
Created attachment 1327188 [details]
ansible running log, intent to undeploy prometheus

Description of problem:
Set openshift_prometheus_state=absent, it did not undeploy prometheus. See the attached ansible log,actually it installed prometheus again.

Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-3.7.0-0.126.4.git.0.3fc2b9b.el7.noarch
openshift-ansible-roles-3.7.0-0.126.4.git.0.3fc2b9b.el7.noarch
openshift-ansible-docs-3.7.0-0.126.4.git.0.3fc2b9b.el7.noarch
openshift-ansible-callback-plugins-3.7.0-0.126.4.git.0.3fc2b9b.el7.noarch
openshift-ansible-filter-plugins-3.7.0-0.126.4.git.0.3fc2b9b.el7.noarch
openshift-ansible-playbooks-3.7.0-0.126.4.git.0.3fc2b9b.el7.noarch
openshift-ansible-lookup-plugins-3.7.0-0.126.4.git.0.3fc2b9b.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. Set openshift_prometheus_state=absent to undeploy prometheus
# cd /usr/share/ansible/openshift-ansible/
# ansible-playbook -vvv -i ${INVENTORY_FILE}   playbooks/byo/openshift-cluster/openshift-prometheus.yml
2.
3.

Actual results:
prometheus was not undeployed, it installed prometheus again

Expected results:
prometheus should be undeployed.

Additional info:
#inventory file
[OSEv3:children]
masters
etcd
nfs

[masters]
${MASTER_URL} openshift_public_hostname=${MASTER_URL}

[etcd]
${ETCD} openshift_public_hostname=${ETCD}

[nfs]
${NFS} openshift_public_hostname=${NFS}

[OSEv3:vars]
ansible_ssh_user=root
ansible_ssh_private_key_file="~/libra.pem"
deployment_type=openshift-enterprise
openshift_docker_additional_registries=brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888

# Prometheus
openshift_prometheus_state=absent
openshift_prometheus_namespace=prometheus

Comment 1 Zohar Gal-Or 2017-11-20 14:26:43 UTC
Submitted fix: https://github.com/openshift/openshift-ansible/pull/6180

Comment 2 Junqi Zhao 2017-11-22 00:35:22 UTC
This defect can be closed now, but we have another issue: https://bugzilla.redhat.com/show_bug.cgi?id=1508310

Comment 3 Zohar Gal-Or 2017-11-22 08:54:41 UTC

*** This bug has been marked as a duplicate of bug 1508310 ***


Note You need to log in before you can comment on or make changes to this bug.