Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1490488 - Azure Smart State on Windows VM throwing error "undefined method `[]' for nil:NilClass" in evm.log
Summary: Azure Smart State on Windows VM throwing error "undefined method `[]' for nil...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Jerry Keselman
QA Contact: Satyajit Bulage
URL:
Whiteboard: smartstate:azure:vm
: 1502751 (view as bug list)
Depends On:
Blocks: 1515482 1515483
TreeView+ depends on / blocked
 
Reported: 2017-09-11 18:06 UTC by Satyajit Bulage
Modified: 2018-06-21 20:37 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1515482 1515483 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:37:55 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Satyajit Bulage 2017-09-11 18:06:29 UTC
Created attachment 1324536 [details]
evm.log during SSA on VM's

Description of problem: Perform SSA on Windows VM throws "undefined method `[]' for nil:NilClass" error and not capturing Application list from Windows VM.


Version-Release number of selected component (if applicable):5.8.2.0.20170824192913_b09a5f8


How reproducible:100%


Steps to Reproduce:
1. Add Azure provider
2. Perform SSA on Windows VM 
3.

Actual results: Throwing error "undefined method `[]' for nil:NilClass" in evm.log


Expected results: There should no error in evm.log also scan should retrieve Application from VM.


Additional info:

Comment 2 Rich Oliveri 2017-09-11 20:31:43 UTC
Jerry,

Is this addressed by your managed disk/snapshot work?

Comment 3 Jerry Keselman 2017-09-11 20:55:37 UTC
I don't think so.  I am running SSA on 4 different Windows VMs that are completing but I am seeing filesystem errors in the log on some of them.  Also some issues with too much data throughput in a short amount of time - probably because I'm running them all concurrently - which could result in data missing.  This will require further investigation.

Comment 4 Dave Johnson 2017-09-21 14:36:27 UTC
Brad, please weigh in on how big of a deal this is.  We set priority to medium but fear it should be higher.

Comment 5 Dave Johnson 2017-09-21 15:25:19 UTC
Satyajit, just to be clear, this only affects Azure?  The application lists are successfully pulled from windows VMs on saw VMware or RHEV?

I spoke to Brad, he wants us confirm its not a specific OS (Jerry's comment 3 seems to indicate that) and that it is isolated to Azure.

Comment 7 Jerry Keselman 2017-09-22 16:43:12 UTC
Again just to be clear - this is not an issue that occurs on *all* Windows VMs regardless of provider type.  Needs to be investigated certainly.  It would be nice to determine what the characteristics are for the Windows systems exhibiting this issue.

Comment 9 Jerry Keselman 2017-11-17 14:26:03 UTC
*** Bug 1502751 has been marked as a duplicate of this bug. ***

Comment 11 Jerry Keselman 2017-11-17 17:52:23 UTC
https://github.com/ManageIQ/manageiq-smartstate/pull/45 fixes this issue.  This may be showing up in various ways in other open BZs as well - will have to search through my list.

Comment 12 Jerry Keselman 2017-11-20 19:03:08 UTC
https://github.com/ManageIQ/manageiq-providers-azure/pull/168 allows the most recent GEM version to be used which is now 0.2.4 which has been pushed out.

Comment 15 Jerry Keselman 2017-12-11 22:42:33 UTC
*** Bug 1524415 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.