Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1487759 - [OSP12] tripleo-ansible-inventory is too slow: it takes more than 2 minutes to generate an inventory containing 1 undercloud + 1 controller + 1 compute
Summary: [OSP12] tripleo-ansible-inventory is too slow: it takes more than 2 minutes t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 12.0 (Pike)
Assignee: RHOS Maint
QA Contact: nlevinki
URL:
Whiteboard:
: 1450475 (view as bug list)
Depends On:
Blocks: 1513593
TreeView+ depends on / blocked
 
Reported: 2017-09-01 20:48 UTC by Marius Cornea
Modified: 2018-02-05 19:12 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-validations-7.4.2-0.20171016115241.c2c9bf2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 22:02:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1715428 None None None 2017-09-06 15:48:31 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC
OpenStack gerrit 463726 None None None 2017-11-21 09:30:40 UTC
OpenStack gerrit 498939 None None None 2017-11-21 09:30:20 UTC
OpenStack gerrit 501603 None None None 2017-09-14 12:38:51 UTC

Description Marius Cornea 2017-09-01 20:48:59 UTC
Description of problem:
tripleo-ansible-inventory takes more than 2 minutes to generate an inventory containing 1 undercloud + 1 controller + 1 compute.

Version-Release number of selected component (if applicable):
openstack-tripleo-validations-7.2.1-0.20170818153714.85b7569.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run tripleo-ansible-inventory --list

Actual results:
It takes almost 2 minutes to display the inventory for a minimal deployment.

Expected results:
It should be a matter of seconds to generate the inventory.

Additional info:

In upgrades we use use the inventory for upgrading non controller nodes and this step adds a pretty high delay per node upgrade.

Comment 3 Ana Krivokapic 2017-11-06 15:13:51 UTC
It now takes from 1s to 6s depending on the number of nodes in the setup.

Comment 5 Ana Krivokapic 2017-11-21 09:31:56 UTC
*** Bug 1450475 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2017-12-13 22:02:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.