Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1486759 - TLS for Internal services for mysql/mariadb
Summary: TLS for Internal services for mysql/mariadb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 12.0 (Pike)
Assignee: Damien Ciabrini
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On: 1484601 1510144 1456743 1484499 1484506 1484512 1484517 1484520 1484521 1484524 1484535 1497981 1506020
Blocks: 1484542 1484547 1484550
TreeView+ depends on / blocked
 
Reported: 2017-08-30 13:45 UTC by atelang
Modified: 2019-04-10 13:58 UTC (History)
35 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1484535
Environment:
Last Closed: 2017-12-13 21:59:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Comment 1 Michael Bayer 2017-09-07 16:57:58 UTC
dupe of #1456743 ?

Comment 2 Keith Basil 2017-09-29 18:38:34 UTC
Michael Bayer, updated with a depends on.  thanks.

Comment 4 Damien Ciabrini 2017-11-09 10:56:20 UTC
Now that last bz to encrypt SST traffic [3,4] has move to POST, all the mysql and galera traffic is encrypted when Internal TLS is enabled.

Moving this tracker bz to POST accordingly.

[3] https://bugzilla.redhat.com/show_bug.cgi?id=1497981
[4] https://bugzilla.redhat.com/show_bug.cgi?id=1506020

Comment 7 Udi Shkalim 2017-12-05 12:17:10 UTC
Verified 
TLS setup is deployed and passed HA sanity

Comment 10 errata-xmlrpc 2017-12-13 21:59:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.