Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1486 - pngtopnm from RH 5.2 libgr-progs-2.0.13-13.i386.rpm dumps core!
Summary: pngtopnm from RH 5.2 libgr-progs-2.0.13-13.i386.rpm dumps core!
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libgr
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-11 21:23 UTC by hsauer
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-23 23:47:33 UTC


Attachments (Terms of Use)

Description hsauer 1999-03-11 21:23:33 UTC
Hello,

I have the problem everytime I try to convert a PNG image to
PNM with pngtopnm
from the libgr-progs-2.0.13-13.i386.rpm (RH 5.2) it produces
an PNM image, but
it also get4s me a segmentation fault and a core dump. I can
display the
resulting PNM with xv, but xv reports that the image is
truncated.
I tried libgr-progs-2.0.13-14.i386.rpm from RawHide and
libgr-progs-2.0.13-4.i386.rpm from RedHat 5.0 which I have
been told works on
5.0, but both gave the same results. Might this be an error
in libgpng ? I
needed to rebuild the RH 5.0 RPM, because it was linked
against an older libpng.
Can you reproduce this error ?
Do you have any solution ?

Bye,
Henning

Comment 1 Jeff Johnson 1999-03-23 22:43:59 UTC
Could you attach a sample file to this bug report? Thanks ...

Comment 2 Bill Nottingham 1999-03-23 23:47:59 UTC
Fixed in libgr-2.0.13-17.


Note You need to log in before you can comment on or make changes to this bug.