Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1483456 - Ceilometer can't find nova instance because of name differences
Summary: Ceilometer can't find nova instance because of name differences
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 12.0 (Pike)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
: 1496388 (view as bug list)
Depends On:
Blocks: 1515969
TreeView+ depends on / blocked
 
Reported: 2017-08-21 07:42 UTC by Sasha Smolyak
Modified: 2018-04-03 21:10 UTC (History)
25 users (show)

Fixed In Version: openstack-tripleo-heat-templates-7.0.3-11.el7ost puppet-ceilometer-11.3.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1515969 (view as bug list)
Environment:
Last Closed: 2017-12-13 21:53:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3198662 None None None 2017-09-28 09:26:49 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC
OpenStack gerrit 509180 None None None 2017-10-03 15:09:12 UTC
OpenStack gerrit 509199 None None None 2017-10-03 15:08:44 UTC
OpenStack gerrit 518010 None None None 2017-11-15 18:39:53 UTC

Description Sasha Smolyak 2017-08-21 07:42:55 UTC
Description of problem:
Ceilometer can't find nova instance because of name differences: it appears as compute-2 for ceilometer in ceilometer.conf (host = socket.gethostname()) and as 
host=compute-2.localdomain in nova.conf.
So there are no events sent from that instance.

There are several ways of workaround, from removing host= in
nova.conf to adding it to ceilometer.conf.It should work by default so there should not be any need to add or remove host.

You can add Ceilometer DFG to this bug

Version-Release number of selected component (if applicable):
openstack-nova-conductor-14.0.7-11.el7ost.noarch
openstack-nova-scheduler-14.0.7-11.el7ost.noarch
openstack-nova-cert-14.0.7-11.el7ost.noarch
openstack-nova-api-14.0.7-11.el7ost.noarch
openstack-nova-common-14.0.7-11.el7ost.noarch
openstack-nova-compute-14.0.7-11.el7ost.noarch


openstack-ceilometer-common-7.1.0-2.el7ost.noarch
openstack-ceilometer-notification-7.1.0-2.el7ost.noarch
openstack-ceilometer-central-7.1.0-2.el7ost.noarch
openstack-ceilometer-api-7.1.0-2.el7ost.noarch
openstack-ceilometer-collector-7.1.0-2.el7ost.noarch
openstack-ceilometer-polling-7.1.0-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Deploy puddle 2017-18-18.2
2. Create an instance
3. Observe the instance hostname

Actual results:
The names differ, no resource is found by ceilometer

Expected results:
The ceilometer must find the resource automatically

Additional info:

Comment 1 Sven Anderson 2017-08-25 15:01:57 UTC
If I'm not mistaken the nova.conf is correct, and the ceilometer.conf is wrong. So, I will move it to the Telemetry DFG for now.

Comment 2 Julien Danjou 2017-09-16 12:23:41 UTC
This is only a problem for deployment where hosts do not have fully qualified hostname, e.g. they rely on localdomain.

Comment 5 Chen 2017-09-27 15:12:49 UTC
*** Bug 1496388 has been marked as a duplicate of this bug. ***

Comment 11 Jon Schlueter 2017-11-21 21:25:44 UTC
openstack-tripleo-heat-templates-7.0.3-11.el7ost

Comment 17 errata-xmlrpc 2017-12-13 21:53:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.