Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1479857 - cryptsetup: Fix for unaligned access to hidden truecrypt header caused regression on systems with pagesize > 4KiB
Summary: cryptsetup: Fix for unaligned access to hidden truecrypt header caused regres...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cryptsetup
Version: 7.5
Hardware: ppc64le
OS: Linux
high
high
Target Milestone: rc
: 7.5
Assignee: Ondrej Kozina
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1522983 1479858 1510841
TreeView+ depends on / blocked
 
Reported: 2017-08-09 15:01 UTC by Ondrej Kozina
Modified: 2018-04-10 16:39 UTC (History)
12 users (show)

Fixed In Version: cryptsetup-1.7.4-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1435543
: 1479858 1510841 (view as bug list)
Environment:
Last Closed: 2018-04-10 16:38:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 157487 None None None 2017-08-10 13:39:30 UTC
Red Hat Product Errata RHBA-2018:0915 None None None 2018-04-10 16:39:20 UTC

Description Ondrej Kozina 2017-08-09 15:01:45 UTC
+++ This bug was initially created as a clone of Bug #1435543 +++

- A bugfix for bug #1435543 exposed bug in internal blockwise routines of libcryptsetup (it's a regression in 7.4)

it fails if page size is >4k and we use image in file 
(aligned read fail because it expects file image aligned to the page size. Similar problem is for write, but write code is never called in cryptsetup (truecrypt header support is read-only))

The bug only affects luks headers stored in regular files. Block devices are not affected.

Note: it's related to all archs with page size > 4 KiB, not only ppc64le

Comment 5 Joseph Kachuck 2017-11-08 16:39:44 UTC
Hello,
This bug has been copied as 7.4 z-stream (EUS) bug #1510841

Thank You
Joe Kachuck

Comment 6 Peter Kotvan 2017-11-14 09:14:34 UTC
I was able to reproduce the bug on RHEL-7.3 GA with cryptsetup-1.7.2-1.el7 and verify it on RHEL-7.5-20171107.1 with cryptsetup-1.7.4-4.el7.

Comment 9 errata-xmlrpc 2018-04-10 16:38:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0915


Note You need to log in before you can comment on or make changes to this bug.