Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1478139 - Command "ovirt-log-collector --quiet" is verbose
Summary: Command "ovirt-log-collector --quiet" is verbose
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-log-collector
Classification: oVirt
Component: Core
Version: 4.1.3
Hardware: All
OS: All
unspecified
medium vote
Target Milestone: ovirt-4.2.2
: 4.2.4
Assignee: Douglas Schilling Landgraf
QA Contact: David Necpal
URL:
Whiteboard:
Depends On:
Blocks: 1456888
TreeView+ depends on / blocked
 
Reported: 2017-08-03 17:01 UTC by David Necpal
Modified: 2018-03-29 11:08 UTC (History)
6 users (show)

Fixed In Version: ovirt-log-collector-4.2.4-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-29 11:08:37 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
ylavi: exception+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 86676 ovirt-log-collector-4.2 MERGED ovirt-log-collector: do not print msgs with --quiet 2018-02-14 10:33:31 UTC
oVirt gerrit 87632 ovirt-log-collector-4.2 MERGED ovirt-log-collector: do not print msgs with --quiet 2018-02-14 10:56:56 UTC

Description David Necpal 2017-08-03 17:01:33 UTC
Description of problem:
The output lists information that is not necessary but deletes the necessary information about the name and size of the file.

Version-Release number of selected component (if applicable):
ovirt-log-collector-4.1.3

How reproducible:
Always

Steps to Reproduce:
1.ovirt-log-collector --quiet
2.
3.

Actual results:
[root@dn-0 tmp]# ovirt-log-collector --quiet
This command will collect system configuration and diagnostic
information from this system.
The generated archive may contain data considered sensitive and its
content should be reviewed by the originating organization before
being passed to any third party.
No changes will be made to system configuration.
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to skip): 
Creating compressed archive...

Expected results:
[root@dn-0 tmp]# ovirt-log-collector --quiet
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to skip): 

Additional info:

Comment 1 Sandro Bonazzola 2017-08-07 09:11:50 UTC
Closing as not a bug.
The warning exposed is meant to avoid to generate huge reports which takes hours to complete.

Comment 2 Lukas Svaty 2017-08-31 09:40:26 UTC
(In reply to Sandro Bonazzola from comment #1)
> Closing as not a bug.
> The warning exposed is meant to avoid to generate huge reports which takes
> hours to complete.

Which part is notifying admin about fact it can be a huge report lasting hours?
"""
This command will collect system configuration and diagnostic
information from this system.
The generated archive may contain data considered sensitive and its
content should be reviewed by the originating organization before
being passed to any third party.
No changes will be made to system configuration.
"""

Unfortunately, I do see an issue here, if we decided we want some kind of verbosity during --quite parameter:

1. Agree with reporter, all info should be hidden except asking for password
2. Not sure where this verbose mode is written to, but at least it should be written to stderr
3. If we are indeed writing something out to stdout we should consider at least adding name and path to the archive created, that seems like the most relevant info.

Can you reconsider?

Comment 3 Sandro Bonazzola 2017-09-08 09:29:49 UTC
Reopening as per comment #2

Comment 4 Douglas Schilling Landgraf 2018-01-05 19:46:55 UTC
PR: https://github.com/oVirt/ovirt-log-collector/pull/2

Comment 5 Sandro Bonazzola 2018-01-15 07:43:30 UTC
(In reply to Douglas Schilling Landgraf from comment #4)
> PR: https://github.com/oVirt/ovirt-log-collector/pull/2

Please push to gerrit.ovirt.org; github is backup only.

Comment 6 David Necpal 2018-02-22 13:08:52 UTC
Verified on version ovirt-log-collector-4.2.4-1.el7ev.noarch
 
[root@example]# ovirt-log-collector --quiet
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to skip): 
[root@example]#

Comment 7 Sandro Bonazzola 2018-03-29 11:08:37 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.