Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1477589 - [RFE][Default Route] - Add exclamation mark next to host with no default route
Summary: [RFE][Default Route] - Add exclamation mark next to host with no default route
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.2.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks: 1200963
TreeView+ depends on / blocked
 
Reported: 2017-08-02 12:29 UTC by Michael Burman
Modified: 2018-02-22 10:01 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-22 10:01:19 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
mburman: testing_plan_complete+
ylavi: planning_ack+
rule-engine: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 82805 master ABANDONED core: Add defaultRoute indicator to VDS 2017-11-21 07:58:20 UTC
oVirt gerrit 82806 master ABANDONED webadmin: Add message to Host without default route 2017-11-21 11:03:26 UTC
oVirt gerrit 83034 master MERGED webadmin: Support multiple tooltips in HostStatusCell 2017-12-15 12:46:07 UTC
oVirt gerrit 84305 master MERGED webadmin: Add message to Host without default route 2017-11-29 17:32:37 UTC
oVirt gerrit 85492 master MERGED webadmin: Fix wrong position of callback in code 2017-12-17 10:17:24 UTC
oVirt gerrit 86093 master MERGED webadmin: Check if default route reporting is supported by VDSM 2018-01-28 10:13:04 UTC

Description Michael Burman 2017-08-02 12:29:25 UTC
Description of problem:
[Default Route] - Add warning or notify the admin that the host has no default route.

As it was decided to close and not fix BZ 1476804 it is very possible that users will found them self in a situations they have no default route on the host.
If we not blocking to set a non-mgmt network with default route while not being attached to any host, we will end up without default route on the host. 

It is very important to have an indication about such case. Admin/user should be notified that the host/s have no default route.

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170801164139.git9b399c8.el7.centos

Comment 1 Yaniv Kaul 2017-09-18 13:35:53 UTC
I don't think it's high.
We could do it via an Ansible running in cron job and inject an event if needed.

Comment 2 Dan Kenigsberg 2017-09-20 22:37:46 UTC
I think that Burman is looking for for an exclamation mark next to host with no default route, not a periodic alert. I find periodic alert disturbing, as hosts with no gateway and no default route are perfectly usable and reasonable to have.

Comment 3 Ales Musil 2017-10-09 10:13:56 UTC
Hi Michael,
in which places it should be displayed? Main host tab, Clusters -> Hosts or both?

Comment 4 Dan Kenigsberg 2017-10-09 18:33:43 UTC
Both. If a host has no fencing configuration an exclamation mark shows on both places. Hovering above it, gave the reason(s) for it (such as no fencing config) in the old UI. That the tooltip functionality seems to be currently broken, but I'd like to see it restored, and to include a warning about a host with no default route.

Comment 5 Ales Musil 2017-10-12 09:36:58 UTC
The tooltip is not broken but was replaced by status report only. Do we want to display additional message under status if something went wrong with host? This messages are currently in general host tab.

Comment 6 Dan Kenigsberg 2017-10-12 11:24:21 UTC
Yes, let's add this under "Action Items".

Do you know if there's a UX bug on how the exclamation shows on the cluster sub-tab (almost hidden by the separator)? Or why there is no hyperlink from the cluster sub-tab hosts to the host details?

Comment 7 Ales Musil 2017-10-13 08:30:05 UTC
The almost hidden exclamation mark will be resolved in the patch as well. But I am not sure about the link to host details. From my point of view it looks like it would be pretty complicated, but maybe someone from UX team can give us hints if it is worth the effort.

Comment 8 Michael Burman 2017-10-15 07:50:11 UTC
(In reply to Ales Musil from comment #3)
> Hi Michael,
> in which places it should be displayed? Main host tab, Clusters -> Hosts or
> both?

Hi, on both please, as Dan mentioned. 
Currently the exclamation mark give no tooltip with no info explaining why the exclamation mark is there.
The only place we have the info of why is under 'Action Items' and i actually would like to see this info on the tooltip when hovering on top of the exclamation mark.

Comment 9 Ales Musil 2017-10-18 13:06:00 UTC
Hi Michael,

do we want show warning before we get reported configuration from host (e.g. on creation of new host)? Or is it suitable enough to get this warning after it gets reported?

Comment 10 Michael Burman 2017-10-18 14:08:02 UTC
(In reply to Ales Musil from comment #9)
> Hi Michael,
> 
> do we want show warning before we get reported configuration from host (e.g.
> on creation of new host)? Or is it suitable enough to get this warning after
> it gets reported?

Hi Ales,
Good question, actually not sure, it can be nice.  
Let's ask Dan, but if we decide that yes, then this warning should appear when adding new host that has no default route and when editing a non-mgmt network with default route role while still not attached to the host.

Comment 11 Dan Kenigsberg 2017-10-24 08:30:08 UTC
(In reply to Michael Burman from comment #10)
> (In reply to Ales Musil from comment #9)
> > Hi Michael,
> > 
> > do we want show warning before we get reported configuration from host (e.g.
> > on creation of new host)? Or is it suitable enough to get this warning after
> > it gets reported?
> 
> Hi Ales,
> Good question, actually not sure, it can be nice.  
> Let's ask Dan, but if we decide that yes, then this warning should appear
> when adding new host that has no default route and when editing a non-mgmt
> network with default route role while still not attached to the host.

I would not mix this idea with this bug. Let us limit this bug for raising a warning on existing hosts with no default route.

I is a nice idea to add the warning to HostSetupNetwork dialog, too, but I'm not sure where, as that dialog is already overcrowded with information.

Comment 12 Dan Kenigsberg 2017-10-24 08:35:07 UTC
It is better to warn the use only after we have the first getCaps in our hands, but I can live with a temporary warning that would go away quickly.

Comment 13 Roberto N 2017-12-17 17:52:46 UTC
There's a way to work around this issue ?
I'm almost sure that in a HC gluster deploy, this happen only where host 2 and 3 are imported.

I'm using ovirt-node-ng 20171215 rc3 image to install hosts.

Comment 14 Michael Burman 2017-12-19 14:38:14 UTC
(In reply to Roberto N from comment #13)
> There's a way to work around this issue ?
> I'm almost sure that in a HC gluster deploy, this happen only where host 2
> and 3 are imported.
> 
> I'm using ovirt-node-ng 20171215 rc3 image to install hosts.

Hi Roberto,

The issue is currently was caused by this fix and already has a patch that fix it as well.

This message will appear only for hosts that has no default route on the host. 
BTW - It's an engine bug and not vdsm, so the fix will be on the engine side and not the node side.

Comment 15 Michael Burman 2018-01-08 08:56:45 UTC
We decided to assign this bug back as some small gap still exist when 3.6 host running in the engine. 

The UI will report that this host has no default route on the host. 
The notification/exclamation mark should show up only on clusterLevel >= 4.1

Comment 16 Alex Kaouris 2018-01-29 14:42:40 UTC
I am wondering if this is fixed. When trying with ovirt 4.2 I hit this bug and VMs were refusing to migrate at the affected host.

Comment 17 Ales Musil 2018-01-30 07:17:14 UTC
Hi Alex,

this warning is only displayed in UI and should not affect migration at all. 

For the migration problem please send email to users@ovirt.org or open new bug report and add vdsm.log, supervdsm.log from the host and engine.log.

Comment 18 Alex Kaouris 2018-02-08 12:02:30 UTC
Noted Ales. 
I erroneously linked this behaviour with this issue. 
I was able at some point to live migrate. 
I will update from 4.2.0 to 4.2.1 to see if this issue is fixed.

Comment 19 Michael Burman 2018-02-21 13:56:22 UTC
Verified on - 4.2.2-0.1.el7 

Scenarios tested - 

- Clusters > Logical Networks flow - PASS
- Logical Networks > Cluster flow - PASS
- Add host with default route - PASS
- Add host without default route - PASS
- Add 3.6 host to cluster 3.6 - PASS 

Exclamation mark will be only reported and disblayed for hosts that report default route property, which means 4.1=< only.

Comment 20 Sandro Bonazzola 2018-02-22 10:01:19 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.