Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 147544 - Anaconda shows a VG as being one PE smaller than vgs/lvs claims (LVM2)
Summary: Anaconda shows a VG as being one PE smaller than vgs/lvs claims (LVM2)
Keywords:
Status: CLOSED DUPLICATE of bug 428756
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard: bzcl34nup
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-09 01:25 UTC by Ignacio Vazquez-Abrams
Modified: 2008-04-24 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-24 16:49:43 UTC


Attachments (Terms of Use)

Description Ignacio Vazquez-Abrams 2005-02-09 01:25:26 UTC
Here's the output from vgs/lvs:

[root@ignacio ~]# vgs --units m
  VG     #PV #LV #SN Attr  VSize      VFree
  WD160A   1   3   0 wz--n 152528.00M    0M
[root@ignacio ~]# lvs --units m
  LV   VG     Attr   LSize      Origin Snap%  Move Copy%
  home WD160A -wi-a- 130512.00M
  root WD160A -wi-a-  20480.00M
  swap WD160A -wi-a-   1536.00M

Here's what Anaconda claims:

Volume Group Name: WD160A
Physical Extent: 4 MB (control is disabled)
Used Space: 152528.00 MB (100%)
Free Space: -4.00 MB (-0.0%)
Total Space: 152524.00 MB

The logical volumes are exactly how lvs shows them.

Comment 1 Peter Jones 2006-02-28 15:24:01 UTC
Do you see this with more recent distros?  I think I fixed this long ago, but
missed this bug when updating them.

Comment 2 Ignacio Vazquez-Abrams 2006-02-28 23:37:23 UTC
Still there with both FC4 and devel.

Comment 3 Bug Zapper 2008-04-03 15:52:10 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 4 Joel Andres Granados 2008-04-24 13:10:25 UTC
A lot of work has gone in to the partitioning stuff from that time.  I think we
do a better job in current f9.  Please reopen if the issue is still present.

Comment 5 Joel Andres Granados 2008-04-24 16:49:43 UTC

*** This bug has been marked as a duplicate of 428756 ***


Note You need to log in before you can comment on or make changes to this bug.