Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 14741 - Missing file /usr/share/magic.mime
Summary: Missing file /usr/share/magic.mime
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard: Winston gold
: 76821 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-27 18:29 UTC by Enrico Scholz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-15 00:29:36 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2000-07-27 18:29:45 UTC
/usr/share/magic.mime is needed for the -i option:

$ file -i core
file: couldn't find any magic files!
[... copying magic.mime ...]
$ file -i core
core: application/x-coredump

I don't know which magic.mime file is the best one. The 'file' package
itself contains such a file, but 'gnome-libs' is installing /etc/mime-magic
which seems to be more extensive.

Comment 1 Glen Foster 2000-07-30 21:48:09 UTC
This defect is considered MUST-FIX for Winston Gold-release

Comment 2 Jeff Johnson 2000-07-31 18:23:32 UTC
A copy of /etc/mime-magic is now included as /usr/share/magic.mime, that should
fix
the critical Winston problem.

However, since /etc/mime-magic (from gnome-libs) and /usr/share/magic.mime (from
file) are copies, this bug is almost certainly gonna crop up again unless 
	1) only one of the packages file and gnome-libs owns the file contents.
	2) both file and gnome (and KDE and ...)  start using the same path to the file
contents.

DEFERRED to gnome-libs for contemplation.

Comment 3 Jeff Johnson 2002-10-27 16:12:23 UTC
Yup, here comes the problem from file(1) again,
the gnome-libs copy of /usr/share/mime.magic
has been replaced with the file copy.

Off to gnome-libs for answers to:

1) Which package, gnome-libs or file, should
carry "official" mime types onto the file system?
I'd suggest file, but understand OTOH too.

2) Can we get a unified copy of mime types onto
a common path for both file and gnome-libs?





Comment 4 Jeff Johnson 2002-10-27 16:14:12 UTC
*** Bug 76821 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Johnson 2002-10-27 16:46:59 UTC
Bounce back to file with the answers, and I'll be happy
to do the work :-)


Note You need to log in before you can comment on or make changes to this bug.