Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1473 - pdksh + glibc2.1 = coredump on startup (trap.c ~line 34)
Summary: pdksh + glibc2.1 = coredump on startup (trap.c ~line 34)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pdksh
Version: 1.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
: 1408 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-10 19:51 UTC by jmegq
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-17 20:48:39 UTC


Attachments (Terms of Use)

Description jmegq 1999-03-10 19:51:19 UTC
With glibc 2.1, pdksh coredumps on startup.
GDB says this occurs in trap.c around line 34, where
it attempts to fill in a list of signal descriptions
using sys_siglist.

Workaround: after running configure, comment out
the HAS_SYS_SIGLIST line in config.h, then compile
as usual.  sys_siglist says it's "only for compatability"
in 2.1, but it appears not to be so compatable...

Comment 1 Jeff Johnson 1999-03-17 20:43:59 UTC
*** Bug 1408 has been marked as a duplicate of this bug. ***

Ksh segfaults on any script I try to run. For example:

-----------------------------------------
#!/bin/ksh

echo foo
-----------------------------------------

------- Additional Comments From abel@bfr.co.il  03/16/99 10:53 -------
Actually it is enough to invoke 'ksh' from command line to see it
crashing. It is still relevant in 5.8.6 (pdksh-5.2.12-7)

Comment 2 Jeff Johnson 1999-03-17 20:48:59 UTC
Fixed in pdksh-5.3.12-2 (by checking that sys_siglist[i] != NULL).
Thanks.


Note You need to log in before you can comment on or make changes to this bug.