Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1467 - resolver(5) "sortlist" option missing
Summary: resolver(5) "sortlist" option missing
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 5173 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-10 05:51 UTC by bentlema
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-04 23:54:35 UTC


Attachments (Terms of Use)

Description bentlema 1999-03-10 05:51:09 UTC
The file resolv/res_init.c in the glibc-2.0.7 tree has
some conditional code which depends on  RESOLVSORT  being
defined.

Building glibc-2.0.7 from the SRPM results in an RPM without
the "sortlist" functionality because the RESOLVSORT isn't
defined anywhere.

To fix the problem, I just added a -DRESOLVSORT in the
resolv/Makefile and rebuilt the rpms.

It would be great if you could include this define in
future releases of the glibc-2.0.7-X.rpm

--Mark

Comment 1 Cristian Gafton 1999-03-23 01:40:59 UTC
That code is experimental and not enough tested. Saying that "it works
for me" is not a guarantee of stability...

------- Email Received From  "Mark A. Bentley" <bentlema@cs.umn.edu> 03/23/99 09:15 -------

Comment 2 jdd 1999-04-23 22:20:59 UTC
"Won't fix it" isn't really a useful approach to the problem --
firstly, the missing functionality is documented in resolver(5), so
its omission from libc constitutes at least a documentation bug.
Secondly, the code is not particularly difficult to audit and test.
Finally, the functionality is quite useful.

Comment 3 bentlema 1999-04-26 16:00:59 UTC
Could you at least leave this job open as a reminder?

Perhaps you could make alternative rpms that people who use this
feature could "install at their own risk."

I've been using the sortlist feature for about a month now without any
problems on the 61 RedHat machines I maintain at our site.

In any case, if you don't feel that testing this code it RedHat's
responsibility, what would  it take to get this included some time
in the future?  If the glibc people said that "yes, this code has
been tested, and their have been no reported problems" would this
been good enough for RedHat?

Comment 4 Cristian Gafton 1999-06-16 15:19:59 UTC
If the glibc people will be happy then they will enable the code by
default. Until then, we are playing it safe.

------- Additional Comments From   09/16/99 19:07 -------
I would agree with bentlema on this one. If you refuse to recognize
the sortlist functionality then at a minimum this should be a doc
bug against the manpage. resolver(5) specifically. Otherwise, I
will assure you that this feature does work. Sun Solaris, and Early
versions of IRIX support it no problem.

Comment 5 Cristian Gafton 1999-09-23 03:53:59 UTC
*** Bug 5173 has been marked as a duplicate of this bug. ***

See bug 1467, I would have re-opened it if I knew how.
Either fix the resolver(5) manpage, or include support
for the sortlist option. I would prefer the latter but
it's really up to you on that.

Comment 6 Cristian Gafton 2000-01-04 23:54:59 UTC
Once again, it isn't turned on because this is not the default
behaviour and the extra work required is in most cases not
needed/wanted.


Note You need to log in before you can comment on or make changes to this bug.