Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1464472 - Must Refresh UI to see Correct Tags of Datastore of vCenter VMware Provider
Summary: Must Refresh UI to see Correct Tags of Datastore of vCenter VMware Provider
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Hilda Stastna
QA Contact: Jadh
URL:
Whiteboard:
: 1515718 1593694 (view as bug list)
Depends On:
Blocks: 1594324 1594326
TreeView+ depends on / blocked
 
Reported: 2017-06-23 13:56 UTC by myoder
Modified: 2019-02-11 13:53 UTC (History)
12 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1594324 1594326 (view as bug list)
Environment:
Last Closed: 2019-02-11 13:53:38 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description myoder 2017-06-23 13:56:25 UTC
Description of problem:
When viewing the datastore overview of a vCenter provider, the tags displayed are the tags of the vCenter Provider.  You must refresh the page for the correct tags to be displayed for the datastore.

Version-Release number of selected component (if applicable):
Tested on CFME 5.7 and 5.8

How reproducible:
Always

Steps to Reproduce:
1. Add vCenter Provider
2. Tag the vCenter Provider
3. Look at the datastore overview page from the vCenter Provider and you will see the tags displayed are for the vCenter provider, and not for the datastore.
4. Click refresh, and the tags will update accordingly.

Actual results:
When viewing the tags of the datastore, the tags of the provider are displayed.  
Expected results:
When viewing the tags of the datastore, the tags of the datastore should be displayed.

Additional info:

Comment 5 Hilda Stastna 2017-07-10 15:01:32 UTC
Thanks Ryan,
I don't need anything else, this was very helpful.
Actually, the bug is not present on master,
but probably still present in Fine version,
so maybe we should change Target release
from cfme-future to 5.8.

Comment 8 Marianne Feifer 2017-10-04 11:34:44 UTC
Dajo, what are you thoughts on this one?  Should someone from QA try to replicate it?

Hilda, customers aren't using master, so testing on that version probably isn't the best way to try to replicate (that's why I'm asking dajo...)

Comment 11 Ruslana Babyuk 2017-10-05 06:44:29 UTC
Hi,

I could reproduce this issue for both versions(5.7, 5.8)
Please find detailed steps:

1. Add vCenter Provider
2. Navigate to provider details page.
3. On provider details page select 'Summary View' view type for the page.
4. Add a tag to the vCenter Provider
5. Click "Datastores" on provider page
6. Check Datastores tag info

Result: Providers tags display for datastores, after refresh datastores tags displays

Additional info: This issue reproduces only if provider details page have a 'Summary View', for 'Dashboard View' tags are not duplicated for datastores

Comment 14 Ruslana Babyuk 2017-11-22 07:45:11 UTC
*** Bug 1515718 has been marked as a duplicate of this bug. ***

Comment 15 Hilda Stastna 2018-01-23 09:59:52 UTC
I want to add that this bug occurs when using ALSO OTHER PROVIDERS, not only with using vCenter VMware Provider.

Comment 16 Hilda Stastna 2018-02-14 16:24:33 UTC
Another note for Ruslana's additional info: the bug also occurs for Dashboard view (not just Summary view), but not always; it depends on how and when you switch between the views when displaying tags.

Comment 17 Hilda Stastna 2018-02-14 17:00:09 UTC
fixing https://github.com/ManageIQ/manageiq-ui-classic/pull/3407

Comment 18 CFME Bot 2018-05-03 17:23:16 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/e1256a03f924684b0da5f0db003cfd5ef7cdb82c
commit e1256a03f924684b0da5f0db003cfd5ef7cdb82c
Author:     Hilda Stastna <hstastna@redhat.com>
AuthorDate: Wed Apr 18 08:42:39 2018 -0400
Commit:     Hilda Stastna <hstastna@redhat.com>
CommitDate: Wed Apr 18 08:42:39 2018 -0400

    Add get_tagdata method to fix displaying correct tags of Datastore

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1464472

    Fix displaying correct tags of Datastore of any provider from Compute >
    Infrastructure > Providers page.

 app/controllers/storage_controller.rb | 1 +
 1 file changed, 1 insertion(+)

Comment 19 Hilda Stastna 2018-06-22 12:35:12 UTC
*** Bug 1593694 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.