Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 146057 - isdn script do not test for 2.6.x kernel module
Summary: isdn script do not test for 2.6.x kernel module
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: isdn4k-utils
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 160675
TreeView+ depends on / blocked
 
Reported: 2005-01-25 00:03 UTC by Uwe Beck
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-17 15:42:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch for /etc/rc.d/init.d/isdn script (deleted)
2005-01-25 00:04 UTC, Uwe Beck
no flags Details | Diff

Description Uwe Beck 2005-01-25 00:03:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Names of 2.6.x kernel modules are *.ko.
The test in /etc/rc.d/init.d/isdn srcipt should be for a *.ko module.
The patch in attachment will fix this mistake.


Version-Release number of selected component (if applicable):
isdn4k-utils-3.2-18.p1.1

How reproducible:
Always

Steps to Reproduce:
1. use isdn with the kernel module in the isdn script
2.
3.
    

Actual Results:  test can never find the kernel module because the
name is false for 2.6.x kernel modules

Expected Results:  correct name for 2.6.x kernel module in isdn script

Additional info:

Comment 1 Uwe Beck 2005-01-25 00:04:49 UTC
Created attachment 110175 [details]
patch for /etc/rc.d/init.d/isdn script

Comment 2 Ngo Than 2005-01-25 09:54:29 UTC
it's now fixed in isdn4k-utils-3.2-22, the new one will be available
in rawhide soon. The module isdn_lzscomp.ko is default disable in
RHEL4, and so this problem will never appear in this case.

I wont do update for RHEL4. Many thanks for your report.

Comment 3 Uwe Beck 2005-02-02 00:27:34 UTC
Now there is an other mistake in /etc/rc.d/init.d/isdn in line:

if [ -f $isdn_path/isdn_lzscomp.o -o -f $$isdn_path/isdn_lzscomp.ko ]
;  then

The correct syntax is:
if [ -f $isdn_path/isdn_lzscomp.o -o -f $isdn_path/isdn_lzscomp.ko ] ;
then

Then it works in RHEL4_BETA2 and I think also in FC. My test is only
in RHEL4.



Comment 4 Ngo Than 2005-02-02 09:48:55 UTC
the typo bug is now fixed in 3.2-23. Thanks for your report.

Comment 8 Issue Tracker 2007-06-20 09:20:33 UTC
Internal Status set to 'Resolved'
Status set to: Closed by Client
Resolution set to: 'Closed by Client'

This event sent from IssueTracker by Uwe Beck 
 issue 63952


Note You need to log in before you can comment on or make changes to this bug.