Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 146 - ping shows buggy numbers about packets
Summary: ping shows buggy numbers about packets
Keywords:
Status: CLOSED DUPLICATE of bug 213
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aboot
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-20 11:26 UTC by pavel.janik
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-04-17 17:21:17 UTC


Attachments (Terms of Use)

Description pavel.janik 1998-11-20 11:26:25 UTC
Try

ping -f localhost as root it should be obvious:

--- localhost ping statistics ---
1847 packets transmitted, 177 packets received, 90% packet
loss
round-trip min/avg/max = 0.9/42.4/84.9 ms

90% is bad...

Comment 1 Preston Brown 1998-11-20 11:44:59 UTC
Not a bug, you are flood pinging.  Not every ping request will come
back.

You are hammering the networking code in the kernel, it can't keep up.

Comment 2 Marc MERLIN 1998-11-28 06:59:59 UTC
Actually Pavel is most likely using a recent 2.1 kernel. There is a
known problem with the ping binary.
Please look at:
http://www.egroups.com/list/linux-kernel/77859.html
http://www.egroups.com/list/linux-kernel/78066.html

(If you don't know who Alexey Kuznetsov is, he did a _lot_ of TCP/IP
work in the 2.1 kernels)

Comment 3 Jeff Johnson 1999-04-17 17:21:59 UTC
*** This bug has been marked as a duplicate of 213 ***


Note You need to log in before you can comment on or make changes to this bug.