Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 145969 - Console fonts are spoiled after Ctrl-Alt-Fx switch from X
Summary: Console fonts are spoiled after Ctrl-Alt-Fx switch from X
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
: 141578 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-01-24 13:59 UTC by Dmitry Butskoy
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-15 13:39:47 UTC


Attachments (Terms of Use)
backported patch from upstream discussion (deleted)
2005-01-24 14:05 UTC, Dmitry Butskoy
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 2277 None None None Never

Description Dmitry Butskoy 2005-01-24 13:59:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040923

Description of problem:

  After switch from X to vt console, console fonts are reset to some
hardware default. Therefore each time after switching users are
compelled to invoke "setsysfont" for console font restoring. It is
needed, because hardware default font just not have national glyphs,
etc...


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21

How reproducible:
Always

Steps to Reproduce:
1. Set console font which differs from hardware-default enough. It is
better if you can type some non-ascii symbols (cyrillic etc.)
2. Switch to X
3. Come back to text console by Ctrl-Alt-Fn , where `n' is a number of
console


Actual Results:    
  Console fonts are changed.
  It is especially appreciable, if you had some non-ascii symbols on
the console screen, and its national language differs from appropriate
vga default (i.e., was "cyrillic", appears "latin" etc.)
 

Expected Results:    
  Console screen must be the same as before initial switch to X

Additional info:

  It is always reproducable for "Intel Corp. 82915G" card.
  Unfortunately, the behavior differs on different types of cards. On
some cards the screen is spoiled, but "setsysfont" is not needed --
newly typed characters are OK.

  This problem has already been mentioned at "freedesktop.org", see
https://bugs.freedesktop.org/show_bug.cgi?id=2277


  IMHO, the bug #141578 is related to it too.

Comment 1 Dmitry Butskoy 2005-01-24 14:05:35 UTC
Created attachment 110121 [details]
backported patch from upstream discussion

  It is a patch from https://bugs.freedesktop.org/show_bug.cgi?id=2277


 , backported to current FC3`s xorg-x11 package.
  It is tested by me on "Intel Corp. 82915G" ("i810" X drv)

Comment 3 Mike A. Harris 2005-02-01 04:10:14 UTC
*** Bug 141578 has been marked as a duplicate of this bug. ***

Comment 4 Mike A. Harris 2005-04-05 18:13:22 UTC
Please upgrade to xorg-x11-6.8.2 which has been released as an update
for Fedora Core 3.  It contains fixes for problems of this nature.

If the problem still occurs after updating and rebooting, please
reopen the report.

Setting status to "ERRATA"

Comment 5 Dmitry Butskoy 2005-04-07 12:37:05 UTC
 Unfortunately, the problem still occurs.

xorg-x11-6.8.2-1.FC3.13
kernel-2.6.10-1_770.FC3

 The same hardware as reported above.



Comment 6 Mike A. Harris 2005-04-11 08:35:39 UTC
Please report the issue to X.Org developers by filing a bug report at
http://bugs.freedesktop.org in the "xorg" component.  Once you've filed
your report to X.Org, if you paste the URL here, Red Hat will track the
issue in X.Org bugzilla with upstream developers, and will review any
fixes that become available for potential inclusion in future Fedora Core
updates.



Comment 7 Dmitry Butskoy 2005-04-12 13:34:31 UTC
  This issue is already at bugs.freedesktop.org, see bug #2277 .
  IMHO They hoped that new kernel 2.6.11 will solve this problem itself, however
it has not occured yet.

  xorg-x11-6.8.2-1.FC3.13, kernel-2.6.11-1.14_FC3, the problem still exist. 


Comment 8 Mike A. Harris 2005-04-15 13:39:47 UTC
Ok, thanks for the update.  Setting status to "UPSTREAM" to track the
problem in the X.Org bugzilla, and we will review any bug fixes that
become available for consideration in future updates.




Note You need to log in before you can comment on or make changes to this bug.