Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1457 - redundant package entries with rpm
Summary: redundant package entries with rpm
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-09 19:33 UTC by bperkins
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-22 20:57:50 UTC


Attachments (Terms of Use)

Description bperkins 1999-03-09 19:33:05 UTC
Had a friend that accidentally upgraded to this version of
rpm (rpm-2.91-17.i386.rpm) on a 5.x system and had lots of
problems.

if one does rpm -i --force package.rpm
on a package that already exist,s it reinstalls the
package,  as it ought to, but makes another entry in the rpm
database.  This is a royal pain to fix, since you can't
remove it normally ( you need to use --allmatches) and then
resinstall the packages.

Not sure if it's relevant or fixed already, just thought I'd
mention it.

Comment 1 Joseph Malicki 1999-03-09 20:20:59 UTC
This won't happen if you use -U --force instead of -i --force.

Comment 2 bperkins 1999-03-09 20:56:59 UTC
Fine, but this behavior differs from rpm-2.5.3-5.1, and the behavior,
though not completely irrational isn't rational either.  Also, I
suspect -U will remove packages of lower versions, which may not be
desireable.

Comment 3 Jeff Johnson 1999-03-10 00:54:59 UTC
Ah, you need to do
	rpm --rebuilddb
when switching from rpm-2.5.x to rpm-2.9x. In rpm-2.9x filenames
are stored relatively, while in rpm-2.5.x filenames are absolute.

At least I think that's what the problem is. Please reopen this bug
if I'm wrong.

Comment 4 bperkins 1999-03-10 02:00:59 UTC
the --rebuilddb was run several times, in order to try to fix the
problem.  Let me reiterate that rpm -i --force package.rpm does "the
right thing" in not producing duplicate entries, while 2.91-17
produced duplicate database entires.  The duplicate entries were
impossible to remove without ripping out the rpms and putting them
back in again.  I can't imagine why this is desireable behavior.

  The reason we were doing this in the first place was to install rpms
that were of the same version but a "different build"
Anyway, we "fixed" the problem by downgrading rpm, I just thought
you'd like to know we found this bug, and it probably needs to be
fixed eventually (though not for my benefit). If you still think it's
not a bug then go ahead and close it.

Comment 5 bperkins 1999-03-10 02:03:59 UTC
ah shoot.

> Let me reiterate that rpm -i --force package.rpm does the "right
> thing"

should read

> Let me reiterate that rpm -i --force package.rpm under rpm-2.5.3-5.1
> does the "right thing"

Comment 6 Jeff Johnson 1999-03-22 20:57:59 UTC
I cannot reproduce this problem with rpm-2.93-2. I think
the original problem was caused by either
	neglecting to run rpm --rebuilddb when upgrading to rpm-2.9x
or
	bugs in rpm-2.91
Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.