Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1455955 - web service and UI worker enabled, connection made to RHV-M API
Summary: web service and UI worker enabled, connection made to RHV-M API
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.9.0
Assignee: Jillian Tullo
QA Contact: Alex Newman
URL:
Whiteboard: distributed:zone
Depends On: 1509452
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-26 14:30 UTC by Gellert Kis
Modified: 2018-03-01 13:12 UTC (History)
9 users (show)

Fixed In Version: 5.9.0.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
cfme 5.7
Last Closed: 2018-03-01 13:12:59 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1456406 None None None Never
Red Hat Product Errata RHSA-2018:0380 normal SHIPPED_LIVE Moderate: Red Hat CloudForms security, bug fix, and enhancement update 2018-03-01 18:37:12 UTC

Internal Links: 1456406

Description Gellert Kis 2017-05-26 14:30:12 UTC
Description of problem:

Web service and UI worker only enabled appliance, connection attempt denied to RHEV with isolated (firewall) appliance .

Version-Release number of selected component (if applicable):


How reproducible:
Web service and UI worker only enabled appliance
Add RHEV. 
Attempt to connect to API .


Steps to Reproduce:
1.
2.
3.

Actual results:
connect to RHEV API 

Expected results:
only connect to vmdb 

Additional info:

Comment 3 Jillian Tullo 2017-07-07 15:28:07 UTC
PR: https://github.com/ManageIQ/manageiq-ui-classic/pull/1580 

(other relevant PRs attached to it)

Comment 5 Jillian Tullo 2017-08-03 18:11:10 UTC
Hey Marianne. No they have not been - it's still being worked on.

Comment 7 Jillian Tullo 2017-09-05 11:47:27 UTC
Hi Marianne - still being worked on. To put it into context, ~15 PRs are already involved in this across many repos. It is nearing completion.

Comment 16 errata-xmlrpc 2018-03-01 13:12:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:0380


Note You need to log in before you can comment on or make changes to this bug.