Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 145398 - ifdown doesn't take ppp down.
Summary: ifdown doesn't take ppp down.
Keywords:
Status: CLOSED DUPLICATE of bug 142436
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-01-17 23:33 UTC by Ralph Loader
Modified: 2014-03-17 02:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-05 12:45:58 UTC


Attachments (Terms of Use)
sh -x ifdown-ppp IHug (deleted)
2005-01-23 00:13 UTC, Ralph Loader
no flags Details

Description Ralph Loader 2005-01-17 23:33:47 UTC
Description of problem:

doing an ifdown on a ppp connection doesn't do anything.

Version-Release number of selected component (if applicable):

initscripts-8.03-1
ppp-2.4.2-7
wvdial-1.54.0-3

How reproducible:

Every time

Steps to Reproduce:


1. Use system-config-network to create network device IHug with
hardware device Modem0 on /dev/ttyS1
2. ifup IHug and wait for network to come up.
3. ifdown IHug
  
Actual results:

ppp stays up.

Expected results:

ppp down.

Additional info:

$ cat /etc/sysconfig/networking/devices/ifcfg-IHug
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
ONBOOT=no
USERCTL=yes
PEERDNS=yes
TYPE=Modem
DEVICE=ppp0
BOOTPROTO=dialup
AC=off
BSDCOMP=off
VJCCOMP=off
CCP=off
PC=off
VJ=off
LINESPEED=115200
MODEMPORT=/dev/ttyS1
PROVIDER=IHug
DEFROUTE=yes
PERSIST=no
PAPNAME=suckfish
WVDIALSECT=IHug
MODEMNAME=Modem0
DEMAND=no

$ cat /etc/wvdial.conf
[Modem0]
Modem = /dev/ttyS1
Baud = 115200
SetVolume = 1
Dial Command = ATDT
Init1 = ATZ
Init3 = ATM0L1
FlowControl = CRTSCTS
[Dialer IHug]
Username = ...
Password = ...
Phone = 087300777
Stupid Mode = 1
Init1 = ATZ
Init2 = ATQ0 V1 E1 W1 S0=0 &C1 &D2 +FCLASS=0
Inherits = Modem0

Comment 1 Bill Nottingham 2005-01-18 03:51:27 UTC
Can you post the output of 'sh -x ifdown IHug'?
(You may need to run sh -x on ifdown-ppp).

Comment 2 Ralph Loader 2005-01-23 00:13:23 UTC
Created attachment 110096 [details]
sh -x ifdown-ppp IHug

The ifdown scripts seem to be doing their job.	They are sending SIGTERM to the
ppp-watch process.

Comment 3 Ralph Loader 2005-01-23 00:18:31 UTC
Here's strace's of the ppp-watch processes.  (I used strace -p after
connecting, so only the shutdown of ppp-watch is present).  There were
two ppp-watch processes running - is that normal?

ppp-watch seems to be looking for the wrong file -
/var/run/ppp-IHug.pid - that doesn't exist but ppp-ifcfg-IHug.pid does.

# cat ppp-watch-7963.trace
--- SIGTERM (Terminated) @ 0 (0) ---
sigreturn()                             = ? (mask now [HUP INT TERM
CHLD IO])
open("/var/run/ppp-IHug.pid", O_RDONLY) = -1 ENOENT (No such file or
directory)
clone(child_stack=0,
flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0xb7ff4928) = 8013
waitpid(8013, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0) = 8013
write(4, "#", 1)                        = 1
close(4)                                = 0
unlink("/var/run/pppwatch-ppp0.pid")    = 0
exit_group(35)                          = ?

# cat ppp-watch-7949.trace
read(3, "#", 1)                         = 1
write(2, "Failed to activate IHug with err"..., 38) = 38
exit_group(35)                          = ?


Comment 4 Ralph Loader 2005-01-23 00:27:32 UTC
In case it's helpful, here are the ppp-watch and pppd command lines,
as per ps:

 8181 ?        S      0:00 /sbin/ppp-watch IHug
 8195 ?        Ss     0:00 /sbin/ppp-watch IHug
 8197 ttyS1    Ss+    0:00 pppd lock modem crtscts asyncmap 00000000
defaultroute usepeerdns user suckfish remotename ifcfg-IHug nodetach
/dev/ttyS1 115200 ipparam ifcfg-IHug linkname ifcfg-IHug call
ifcfg-IHug noauth

Comment 5 Miloslav Trmač 2006-03-05 12:45:58 UTC

*** This bug has been marked as a duplicate of 142436 ***


Note You need to log in before you can comment on or make changes to this bug.