Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1450475 - Execution time of /bin/tripleo-ansible-inventory way too high
Summary: Execution time of /bin/tripleo-ansible-inventory way too high
Keywords:
Status: CLOSED DUPLICATE of bug 1487759
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 12.0 (Pike)
Assignee: Florian Fuchs
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1513593
TreeView+ depends on / blocked
 
Reported: 2017-05-12 17:17 UTC by Andreas Karis
Modified: 2017-12-01 17:01 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-validations-7.4.2-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1513593 (view as bug list)
Environment:
Last Closed: 2017-11-21 09:31:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 463726 None None None 2017-09-05 10:10:32 UTC
OpenStack gerrit 498939 None None None 2017-09-05 10:17:41 UTC
OpenStack gerrit 501603 None None None 2017-11-01 16:39:49 UTC

Description Andreas Karis 2017-05-12 17:17:44 UTC
Description of problem:
Execution time of /bin/tripleo-ansible-inventory way too high

Version-Release number of selected component (if applicable):
[root@undercloud-4 ~]# rpm -qf /bin/tripleo-ansible-inventory
openstack-tripleo-validations-5.5.0-1.el7ost.noarch

Actual results:
[stack@undercloud-4 ~]$ time tripleo-ansible-inventory --list
{"overcloud": {"children": ["controller", "compute"], "vars": {"ansible_ssh_user": "heat-admin"}}, "controller": ["192.168.24.12"], "undercloud": {"hosts": ["localhost"], "vars": {"overcloud_horizon_url": "http://10.0.0.5:80/dashboard", "overcloud_admin_password": "dzd8PRdB4TWGGygkCDGdUHrkY", "ansible_connection": "local"}}, "compute": ["192.168.24.9", "192.168.24.7"]}

real	1m12.398s
user	0m0.779s
sys	0m0.110s


Expected results:
< 1 second execution time on any system

Additional info:
run in a virtual undercloud, however, as this doesn't do anything more than list a few hosts and passwords, it should not take this long

Comment 3 Florian Fuchs 2017-09-05 10:17:18 UTC
There have been several performance improvements to the inventory in Ocata (backported) and Pike.

However, because there are a number of API calls involved when creating the dynamic inventory result, expecting an execution time of < 1s is maybe not realistic. The inventory has a --static-inventory option though which writes the result to a static inventory file. This should help where performance is critical.

Comment 7 Ana Krivokapic 2017-11-21 09:31:56 UTC

*** This bug has been marked as a duplicate of bug 1487759 ***


Note You need to log in before you can comment on or make changes to this bug.