Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 144903 - rhn-applet crashes due to entries within sources file - KeyError: url
Summary: rhn-applet crashes due to entries within sources file - KeyError: url
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhn-applet
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Shannon Hughes
QA Contact: Max Spevack
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-12 16:59 UTC by Clifford Perry
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:09:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Clifford Perry 2005-01-12 16:59:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
The new version of RHN Applet released during Update 4 for Enterprise
Linux 3 included code to allow RHN Applet to parse the
/etc/sysconfig/rhn/sources file to give APT and YUM support into the
application (matching similar features given in up2date which also
uses this file).

It seems though that if specify within the sources file that you have
local disk repo, such as :

dir my-favorite-rpms-i386-9 /var/spool/RPMS/

Then rhn-applet-gui and rhn-applet-tui will both fail with the
following traceback message :

Traceback (most recent call last):
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 460, in
refresh_handler
    self.refresh(force)
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 577, in
refresh
    if self.nag_check():
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 533, in
nag_check
    self.model.get_caps()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_model.py", line
255, in get_caps
    self.fully_initialized()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_model.py", line
368, in fully_initialized
    self.__build_sources()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_model.py", line
134, in __build_sources
    rhn_utils.log_debug("Failed to initialize source %s for %s : %s
%s" % (
KeyError: url 

Version-Release number of selected component (if applicable):
rhn-applet-2.1.18-4

How reproducible:
Always

Steps to Reproduce:
1. Configure up2date to use a local disk repo for RPMS
2. Use up2date sucessfully
3. Watch rhn-applet-{gui,tui} traceback and fail due to the entries


Additional info:

Comment 1 Adrian Likins 2005-01-14 19:32:06 UTC
Hmm, interesting. The applet simply doesn't implement
`dir` style repos. It probably should. Or at very
least, not traceback on it.

Comment 2 RHEL Product and Program Management 2007-10-19 19:09:19 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.