Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1447 - libc installed with debugging info by default
Summary: libc installed with debugging info by default
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-07 14:49 UTC by cinlar
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-04-08 21:30:35 UTC


Attachments (Terms of Use)

Description cinlar 1999-03-07 14:49:42 UTC
/usr/lib/libc-2.0.7.so and /usr/lib/libc.a are installed by
default with debugging symbols. The source is not installed
by default, this caused gdb to stop every time a C function
is stepped. The desired result is to simply step over the C
function as is the case in Redhat 4.2, SUSE, and Debian.
strip -g /usr/lib/libc.a reduces the file size from 7.5M to
~1.5M and cures the gdb problem for statically linked
binaries. a copy of /lib.libc-2.0.7.so goes from 3.5M to
~750K but I have yet to figure out how to get the programs
to link with the new lib. If this is NOT a bug what hte
proper switch to tell gdb not to crash every time a C
function is stepped over?

Comment 1 David Lawrence 1999-04-08 21:30:59 UTC
We will probably not change this for the next release of Red Hat.


Note You need to log in before you can comment on or make changes to this bug.