Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1445663 - Improve performance with xattrop update.
Summary: Improve performance with xattrop update.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Sunil Kumar Acharya
QA Contact:
URL:
Whiteboard: rebase
Depends On:
Blocks: 1509830
TreeView+ depends on / blocked
 
Reported: 2017-04-26 09:02 UTC by Sunil Kumar Acharya
Modified: 2017-12-08 17:33 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1499150 1509830 (view as bug list)
Environment:
Last Closed: 2017-12-08 17:33:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sunil Kumar Acharya 2017-04-26 09:02:12 UTC
Description of problem:
xattrop update on bricks is very slow.

Comment 1 Worker Ant 2017-05-02 10:10:08 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#1) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 2 Worker Ant 2017-05-04 07:21:24 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#2) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 3 Worker Ant 2017-05-04 17:29:00 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#3) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 4 Worker Ant 2017-05-12 07:30:48 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#4) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 5 Worker Ant 2017-05-12 07:34:51 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#5) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 6 Worker Ant 2017-05-12 15:11:45 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#6) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 7 Worker Ant 2017-05-12 15:16:55 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#7) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 8 Worker Ant 2017-05-12 15:34:24 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#8) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 9 Worker Ant 2017-06-09 06:59:17 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#9) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 10 Worker Ant 2017-06-09 12:15:31 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#10) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 11 Worker Ant 2017-06-13 09:07:20 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#11) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 12 Worker Ant 2017-06-13 12:09:40 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#12) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 13 Worker Ant 2017-08-30 06:41:24 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#13) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 14 Worker Ant 2017-09-13 06:37:46 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#14) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 15 Worker Ant 2017-09-19 14:38:41 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#15) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 16 Worker Ant 2017-09-25 04:45:10 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#16) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 17 Worker Ant 2017-09-28 15:05:42 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#17) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 18 Worker Ant 2017-10-04 11:43:58 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#18) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 19 Worker Ant 2017-10-04 13:06:27 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#19) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 20 Worker Ant 2017-10-04 15:16:17 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#20) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 21 Worker Ant 2017-10-05 06:40:25 UTC
REVIEW: https://review.gluster.org/17151 (cluster/ec: Improve performance with xattrop update) posted (#21) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)

Comment 22 Worker Ant 2017-10-06 01:42:10 UTC
COMMIT: https://review.gluster.org/17151 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 12cfc1983fa1521d6da94ad488145182cf97db2c
Author: Sunil Kumar Acharya <sheggodu@redhat.com>
Date:   Fri Apr 28 18:09:01 2017 +0530

    cluster/ec: Improve performance with xattrop update
    
    Existing EC code updates the xattr on the subvolume
    in a sequential pattern resulting in very poor performance.
    
    With this fix EC now updates the xattr on the subvolume
    in parallel which improves the xattr update performance.
    
    BUG: 1445663
    Change-Id: I3fc40d66db0b88875ca96a9fa01002ba386c0486
    Signed-off-by: Sunil Kumar Acharya <sheggodu@redhat.com>

Comment 23 Shyamsundar 2017-12-08 17:33:42 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.