Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 144550 - VESA driver fails on Gigabyte GA-K8VM800M (K8M800)
Summary: VESA driver fails on Gigabyte GA-K8VM800M (K8M800)
Status: CLOSED DUPLICATE of bug 145200
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 3
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
: 144549 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2005-01-08 03:23 UTC by Jeff Schultz
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-01-17 03:31:07 UTC

Attachments (Terms of Use)

Description Jeff Schultz 2005-01-08 03:23:16 UTC
Description of problem:

VESA driver in x86_64 FC3 fails during VBE calls on K8M800-based board
with AMD64 3000 CPU.  Can persuade it to work in a 32-bit install
of SUSE 9.1, and it sort of worked with 32-bit FC2.

The X server is not something I'm familiar with, but a bit of manual
debugging found that the xf86ExecX86int10 call in VBEGetModeInfo is
yielding 0x14f instead of the desired 0x4f for every mode tried.
This leads to VESAPreInit's giving up and the line

    (EE) VESA(0): No matching modes

in the X log.

(Attempts with the unichrome project driver failed for this board.
K8M800 support not there yet.  The old VIA driver is not present in
the x86_64 distribution for some reason, so I'm a bit stuck.)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install x86_64 FC3 on this hardware.
2. Try the X VESA driver.
Actual results:

    (EE) VESA(0): No matching modes

Expected results:

Working X in some suitable resolution.

Additional info:

Not restricted to this MB---from others' comments, there seems to be
a bit of a problem with this chipset on all MBs using it.

Comment 1 Jeff Schultz 2005-01-10 08:38:07 UTC
*** Bug 144549 has been marked as a duplicate of this bug. ***

Comment 2 Warren Togami 2005-01-17 03:31:07 UTC

*** This bug has been marked as a duplicate of 145200 ***

Note You need to log in before you can comment on or make changes to this bug.