Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 144494 - Large number of files in home directory causes OpenMotif crash
Summary: Large number of files in home directory causes OpenMotif crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openmotif
Version: 3.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 180352 RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2005-01-07 18:15 UTC by J. Lewis Muir
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2006-0293
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 14:35:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Makefile for test case program (deleted)
2005-01-07 18:17 UTC, J. Lewis Muir
no flags Details
Test case program (deleted)
2005-01-07 18:18 UTC, J. Lewis Muir
no flags Details
Patch to solve this problem (deleted)
2006-02-02 16:59 UTC, Thomas Woerner
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0293 normal SHIPPED_LIVE openmotif bug fix update 2006-07-19 18:42:00 UTC

Description J. Lewis Muir 2005-01-07 18:15:00 UTC
Description of problem:
An OpenMotif application that creates a MessageBox with an information
icon crashes due to a segmentation fault when there are a large number
of files in the user's home directory.


Version-Release number of selected component (if applicable):
openmotif-2.2.3-4.RHEL3.4

How reproducible:
Always

Steps to Reproduce:
1. Download attached test case files: Makefile and msg-box.c
2. Compile test case program:
   $ make
3. Confirm that the test case works:
   $ ./msg-box
4. Create 4000 files in home directory:
   $ cd
   $ sh -c 'for (( i=0; $i <= 4000; i=$i+1 )); do touch testfile.$i; done'
5. Try the test case again and see it crash:
   $ ./msg-box


Actual Results:  Segmentation fault

Expected Results:  Should not crash.

Additional info:

If I comment out line 15 in the test case program (the line that sets
the information icon for the message box), it does not crash. So perhaps
it is looking for the icon in the home directory or something.

The number of files needed in the home directory to cause it to crash
can vary. It seems to be dependent on the length of the file name. I
named the test files testfile.N. But if I make the names of the test
files longer then fewer test files are needed to get it to crash.

Comment 1 J. Lewis Muir 2005-01-07 18:17:39 UTC
Created attachment 109483 [details]
Makefile for test case program

Comment 2 J. Lewis Muir 2005-01-07 18:18:27 UTC
Created attachment 109484 [details]
Test case program

Comment 3 Thomas Woerner 2006-02-02 16:59:26 UTC
Created attachment 124057 [details]
Patch to solve this problem

Upstream motifzone fix which solves this problem.

Comment 8 Red Hat Bugzilla 2006-07-20 14:35:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0293.html



Note You need to log in before you can comment on or make changes to this bug.