Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1442263 - Review Request: nodejs-follow-redirects - HTTP and HTTPS modules that follow redirects
Summary: Review Request: nodejs-follow-redirects - HTTP and HTTPS modules that follow ...
Keywords:
Status: MODIFIED
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: nodejs-reviews Node-RED
TreeView+ depends on / blocked
 
Reported: 2017-04-13 20:59 UTC by Jared Smith
Modified: 2017-10-05 16:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
zebob.m: fedora-review+


Attachments (Terms of Use)

Description Jared Smith 2017-04-13 20:59:13 UTC
Spec URL: https://jsmith.fedorapeople.org/Packaging/nodejs-follow-redirects/nodejs-follow-redirects.spec
SRPM URL: https://jsmith.fedorapeople.org/Packaging/nodejs-follow-redirects/nodejs-follow-redirects-1.2.3-1.fc27.src.rpm
Description: HTTP and HTTPS modules that follow redirects
Fedora Account System Username: jsmith

Comment 1 Robert-André Mauchin 2017-09-24 15:45:22 UTC
Please update to 1.2.4.


There an issue with the chain of dependencies:

DEBUG util.py:458:   Problem: package nodejs-express-3.5.2-9.fc27.noarch requires npm(connect) = 2.14.5, but none of the providers can be installed
DEBUG util.py:458:    - package nodejs-connect-2.14.5-11.fc27.noarch requires npm(express-session) >= 1.0.2, but none of the providers can be installed
DEBUG util.py:458:    - conflicting requests
DEBUG util.py:458:    - nothing provides npm(utils-merge) = 1.0.0 needed by nodejs-express-session-1.0.2-8.fc27.noarch

nodejs-express-session needs relaxed dep on utils-merge because it depends strictly on version 1.0.0 and utils-merge was updated to 1.0.1 on Rawhide.


Package accepted.

Comment 2 Jared Smith 2017-10-05 16:02:48 UTC
Requested package in ticket https://pagure.io/releng/fedora-scm-requests/issue/2031


Note You need to log in before you can comment on or make changes to this bug.