Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 144167 - system-config-printer hangs when new clicked
Summary: system-config-printer hangs when new clicked
Keywords:
Status: CLOSED DUPLICATE of bug 144536
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
: 153929 155007 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-04 21:29 UTC by Adam Patacchiola
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 08:25:10 UTC


Attachments (Terms of Use)

Description Adam Patacchiola 2005-01-04 21:29:06 UTC
Description of problem:

system-config-printer hangs after new clicked

Version-Release number of selected component (if applicable):

system-config-printer-0.6.116-1


How reproducible:

Always


Steps to Reproduce:
1. click new
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Adam Patacchiola 2005-01-04 21:29:41 UTC
[root@localhost util]# system-config-printer-gui
*** glibc detected *** malloc(): memory corruption: 0x08064fa0 ***
sh: line 1: 27741 Aborted                 perl -e
'ioctl(STDIN,0x84005001,$result);print $result' 2>/dev/null </dev/usb/lp0
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 580, in
new_button_clicked    self.addQueue.addQueueDruid ()
  File "/usr/share/printconf/util/addQueue.py", line 248, in addQueueDruid
    self.populate_device_view ()
  File "/usr/share/printconf/util/addQueue.py", line 468, in
populate_device_view
    self.local_devs = self.parent.conf.scan_local_printer_devices (force)
  File "/usr/share/printconf/util/printconf_conf.py", line 1265, in
scan_local_printer_devices
   
local_printer_devices.device_dict[dev].update(autodetect_usb_printer(dev,
i))
  File "/usr/share/printconf/util/printconf_conf.py", line 1392, in
autodetect_usb_printer
    return { "auto" : auto }
UnboundLocalError: local variable 'auto' referenced before assignment


Comment 2 Tim Waugh 2005-01-05 12:20:09 UTC
Here is a similar report from fedora-list:

  https://www.redhat.com/archives/fedora-list/2004-December/msg05889.html

Could you please try running this as root?:

  perl -e 'ioctl(STDIN,0x84005001,$result);print $result' </dev/usb/lp0

Does that do the same thing?

Comment 3 Adam Patacchiola 2005-01-05 16:22:08 UTC
[root@localhost ~]# perl -e 'ioctl(STDIN,0x84005001,$result);print $result'
</dev/usb/lp0
*** glibc detected *** malloc(): memory corruption: 0x08064f78 ***
Aborted

Apparently so. 

Comment 4 Tim Waugh 2005-01-05 16:53:13 UTC
This is going wrong in the perl program then.  Chip, any idea what's up?

Comment 5 Adam Patacchiola 2005-01-11 16:33:25 UTC
I just noticed that when I run this program at home it does not hang. I have a
notebook that i use in a docking station at work, where the program hangs. The
docking station has a usb parallel printer port emulator. Perhaps something is
going on with that that is causing the problem? Is there a workaround.. I don't
care about using the parallel port?

Comment 6 Tim Waugh 2005-04-06 08:47:34 UTC
*** Bug 153929 has been marked as a duplicate of this bug. ***

Comment 7 Tim Waugh 2005-04-15 15:58:31 UTC
*** Bug 155007 has been marked as a duplicate of this bug. ***

Comment 8 Warren Togami 2005-05-17 23:50:45 UTC
Is this the same issue as Bug #144536?

Comment 9 Tim Waugh 2005-05-19 08:25:10 UTC
Yes, and that bug has a stack trace.

*** This bug has been marked as a duplicate of 144536 ***


Note You need to log in before you can comment on or make changes to this bug.