Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 143960 - wireless tools should use v17
Summary: wireless tools should use v17
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireless-tools
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-01-02 18:12 UTC by Sammy
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-04 20:31:20 UTC


Attachments (Terms of Use)

Description Sammy 2005-01-02 18:12:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) KHTML/3.3.2 (like Gecko)

Description of problem:
Kernel 2.6.10 is updated to V17 of Wireless Extension. Thus the wireless
drivers are compiled with that. This results in warnings etc in system-config-
network via rhpl. I am also filing a report with glibckernheaders which should
be updated as well.

Version-Release number of selected component (if applicable):
wireless-tools

How reproducible:
Always

Steps to Reproduce:
1.update to FC4 with 2.6.10
2.start using a wireless driver
3.system-config-network
    

Additional info:

Comment 1 Dan Williams 2005-01-17 21:27:15 UTC
wireless-tools-28.pre4 has been built into rawhide and fc3-updates,
FYI.  Does that help the problem at all?

Comment 2 Sammy 2005-01-18 01:35:04 UTC
I don't see it ! 

Comment 3 Sammy 2005-01-18 01:50:01 UTC
O.K. I got it from fc3. In the spec file there is a def that sais  =16 
I don't think it has any effect. I made it 17 and rebuilt. It seem ok. 
I'll test it a bit more. Of course this does not fix the rhpl dependence 
on the version 16 through glibc-kernheaders which contains wireless.h 
for Version 16. 

Comment 4 Péter, Soós 2005-01-24 09:47:31 UTC
You should update Fedora Core 2 too.

iwconfig reports the following after kernel update to 2.6.10-1.9_FC2:

Warning: Driver for device eth1 has been compiled with version 17
of Wireless Extension, while this program is using version 16.
Some things may be broken...


Comment 5 Dan Williams 2005-03-12 20:46:22 UTC
than: I believe that kdenetwork depends on wireless-tools too, so it would need to be 
updated in FC2 were I to update wireless-tools to v28.  Is this correct?

Comment 6 Dan Williams 2005-03-12 20:47:31 UTC
than: and by update, I only mean recompile against the new wireless-tools since they two 
are ABI compatible except for the change from "libiw.so.27" -> "libiw.so.28".

Comment 7 Ngo Than 2005-03-13 10:43:13 UTC
yes, kdenetworks needs to be rebuilt against new wireless-tools in
this case

Comment 8 jim 2005-04-01 14:42:36 UTC
I also get the 
"Warning: Driver for device eth1 has been compiled with version 17
of Wireless Extension, while this program is using version 16.
Some things may be broken..." 
 
 installed 
wireless-tools-27-0.pre25.3
2.6.10-1.770_FC3
NetworkManager-gnome-0.3.4-1.1.0.fc3
NetworkManager-0.3.4-1.1.0.fc3

I have kept this PC updated So why the error?

Comment 9 Dan Williams 2005-04-01 14:47:22 UTC
The wireless-tools package needs to be updated, and then kdenetwork,
NetworkManager, and system-config-network all need to be recompiled to match. 
The issue is that updated kernels include later versions of wireless extensions
but wireless-tools doesn't match that version.

Comment 10 Dan Williams 2005-05-04 20:31:20 UTC
A wireless-tools for FC3 was pushed which should fix this issue...

wireless-tools-27-2.2.0.fc3


Note You need to log in before you can comment on or make changes to this bug.