Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1439 - printing BW with a deskjet 500c not working properly
Summary: printing BW with a deskjet 500c not working properly
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ghostscript
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-06 19:31 UTC by Mike Maher
Modified: 2014-03-17 02:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-12 14:19:24 UTC


Attachments (Terms of Use)

Description Mike Maher 1999-03-06 19:31:41 UTC
It appears that the deskjet 500c filter in the 5.2
distribution does not
work correctly when configured to print BW.  I struggled
with this a bit
only to find that

1) the color mode worked fine

2) the non-color deskjet filter works fine for BW (this was
my workaround)

3) if I use the 500C filter it works okay for BW text, but
when handed postscript gs appears to balk with the error:

Unrecoverable error: rangecheck in .putdeviceprops
(1488) op_array(486)0x817b0d4:E... (after the E falls off
the page -
sorry)

Comment 1 Bill Nottingham 1999-03-08 19:16:59 UTC
don't use 1bpp. Use 8bpp instead. (that's still B&W).

The ghostscript driver suddenly became broken.

Comment 2 Bill Nottingham 1999-03-22 23:50:59 UTC
at some point I'll attempt to fix ghostcript, when I have
copious amounts of free time, or a better understanding of
the ghostscript code. Until then, this falls under a 'don't do that.'

Comment 3 Jay Turner 1999-06-29 18:19:59 UTC
Bill, what is the status of this currently??

Comment 4 Bill Nottingham 1999-06-29 18:23:59 UTC
the ghostscript driver is still doesn't like to be configured
for 1bpp, AFAIK. Haven't looked at it recently. New installs
won't be configured to use it; upgrades could run into this issue
though.


Note You need to log in before you can comment on or make changes to this bug.