Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 143351 - initscripts do not allow to fsck -y
Summary: initscripts do not allow to fsck -y
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 168979 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-12-19 21:16 UTC by Need Real Name
Modified: 2014-03-17 02:51 UTC (History)
3 users (show)

Fixed In Version: 8.32-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-10 22:59:40 UTC


Attachments (Terms of Use)
Only use -a if $fsckoptions doesn't already specify -y (deleted)
2006-03-01 03:11 UTC, Miloslav Trmač
no flags Details | Diff

Description Need Real Name 2004-12-19 21:16:50 UTC
initscripts do not allow to automatically check the filesystem 
(option -y of fsck) because -y conflicts with -a
which is set directly in /etc/rc.d/rc.sysinit
I think /etc/rc.d/rc.sysinit should be modified to allow 
-a or -y to be used depending on /etc/sysconfig/autofsck

Currently a remote server can not be booted after an unclean shutdown
because fsck -a often go to manual mode.
fsck -y would not go to manual mode.

Comment 1 Bill Nottingham 2005-10-03 21:43:54 UTC
*** Bug 168979 has been marked as a duplicate of this bug. ***

Comment 2 Miloslav Trmač 2006-03-01 03:11:08 UTC
Created attachment 125443 [details]
Only use -a if $fsckoptions doesn't already specify -y

(Note that this won't work for -otheroptionsy, but -yotheroptions is OK)

Comment 3 Miloslav Trmač 2006-04-10 22:59:40 UTC
Fixed in initscripts-8.32-1.  Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.