Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1428060 - write-behind: Allow trickling-writes to be configurable, fix usage of page_size and window_size
Summary: write-behind: Allow trickling-writes to be configurable, fix usage of page_si...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: write-behind
Version: 3.13
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
: 1512080 (view as bug list)
Depends On:
Blocks: 1426042
TreeView+ depends on / blocked
 
Reported: 2017-03-01 19:05 UTC by Vijay Bellur
Modified: 2018-03-15 11:16 UTC (History)
3 users (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-02 16:03:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijay Bellur 2017-03-01 19:05:17 UTC
write-behind: Allow trickling-writes to be configurable, fix usage of page_size and window_size

Summary:
- It adds a configurable option for "trickling-writes".
- Makes `__wb_preprocess_winds()` use `wb_inode->window_conf` rather
  than `page_size`, so that the window-size option is actually
  respected.
- This is a port of D3576122 & D3738605 to 3.8.

Test Plan:
- Prove test which looks @ brick-level FOPs and ensures
that they fall in the right write-size bucket.

Reviewed By: rwareing

Signature: t1:3576122:1468892648:6923a6a19b18888577ce5173b5c9cb9531f941e7

Change-Id: I379a9f2f0c4768c9052b7e9dd71c5f0469cb2d68
Signed-off-by: Shreyas Siravara <sshreyas@fb.com>
Reviewed-on: http://review.gluster.org/16079
NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Smoke: Gluster Build System <jenkins@build.gluster.org>
Reviewed-by: Kevin Vigor <kvigor@fb.com>
CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 1 Worker Ant 2017-03-03 00:17:51 UTC
REVIEW: https://review.gluster.org/16834 (write-behind: Allow trickling-writes to be configurable, fix usage of page_size and window_size) posted (#1) for review on master by Vijay Bellur (vbellur@redhat.com)

Comment 2 Csaba Henk 2017-12-12 17:01:30 UTC
*** Bug 1512080 has been marked as a duplicate of this bug. ***

Comment 3 Worker Ant 2017-12-12 17:05:09 UTC
REVIEW: https://review.gluster.org/18719 (write-behind: Allow trickling-writes to be configurable) posted (#5) for review on master by Csaba Henk

Comment 4 Worker Ant 2017-12-13 10:22:15 UTC
COMMIT: https://review.gluster.org/18719 committed in master by \"Csaba Henk\" <csaba@redhat.com> with a commit message- write-behind: Allow trickling-writes to be configurable

This is the undisputed/trivial part of Shreyas' patch
he attached to https://bugzilla.redhat.com/1364740 (of
which the current bug is a clone).

We need more evaluation for the page_size and window_size
bits before taking them on.

Change-Id: Iaa0b9a69d35e522b77a52a09acef47460e8ae3e9
BUG: 1428060
Co-authored-by: Shreyas Siravara <sshreyas@fb.com>
Signed-off-by: Csaba Henk <csaba@redhat.com>

Comment 5 Worker Ant 2017-12-20 20:26:13 UTC
COMMIT: https://review.gluster.org/19053 committed in release-3.13 by \"Amar Tumballi\" <amarts@redhat.com> with a commit message- write-behind: Allow trickling-writes to be configurable

This is the undisputed/trivial part of Shreyas' patch
he attached to https://bugzilla.redhat.com/1364740 (of
which the current bug is a clone).

We need more evaluation for the page_size and window_size
bits before taking them on.

Change-Id: Iaa0b9a69d35e522b77a52a09acef47460e8ae3e9
BUG: 1428060
Co-authored-by: Shreyas Siravara <sshreyas@fb.com>
Signed-off-by: Csaba Henk <csaba@redhat.com>

Comment 6 Shyamsundar 2018-01-02 16:03:56 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.1, please open a new bug report.

glusterfs-3.13.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-devel/2017-December/054104.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 7 Shyamsundar 2018-03-15 11:16:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.