Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1427 - ifup-routes failing "linuxconf --hint routing "$1" "
Summary: ifup-routes failing "linuxconf --hint routing "$1" "
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-05 14:01 UTC by francesco.zuliani
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-24 17:13:04 UTC


Attachments (Terms of Use)

Description francesco.zuliani 1999-03-05 14:01:22 UTC
Failure to add static-routes.
In file /etc/sysconfig/network-scripts/ifup-routes
the command "linuxconf --hint routing $1"
fails to give correct results, so that static-routes
specified in /etc/sysconfig/static-routes are not
loaded.

Resolution: comment out part regarding linuxconf in
/etc/sysconfig/network-scripts/ifup-routes

Comment 1 Bill Nottingham 1999-03-19 22:27:59 UTC
what incorrect results does linuxconf give?

Comment 2 Anonymous 1999-03-20 16:59:59 UTC
the command "linuxconf --hint routing eth0" simply return nothings,
but then this prevents "/etc/sysconfig/static-routes" file to be read
and further static routes to be added.

Comment 3 Bill Nottingham 1999-03-22 23:48:59 UTC
Are you running a 2.0 or a 2.2 kernel?

Comment 4 Anonymous 1999-03-23 10:24:59 UTC
I'm running RedHat 5.2 + updates and kernel 2.0.36.
I also noticed that the command
"linuxconf --hint routing" does return the following :
IPV4ROUTING="false"
DEV_RECONF_ROUTES=""

BUT as soon as one puts any argument  (here eth0, but it seems
unrelevant):

linuxconf --hint routing eth0

then linuxconf  fails to give any output and so doing prevents adding
of static routes written in /etc/sysconfig/static-routes

Comment 5 Michael K. Johnson 1999-03-24 16:21:59 UTC
Added Jacques to the CC line

Comment 6 Michael K. Johnson 1999-03-24 17:13:59 UTC
I can't reproduce this with linuxconf 1.14, and we've received
conflicting reports that linuxconf IS giving output from
/etc/sysconfig/static-routes (output that used to work, but
failed with a newer set of network utilities) so I think that this
is specific to Francesco's configuration.  Linuxconf is probably
looking at the device configuration and is not able to find a
device to which the static route applies.  Unless the gateway is
directly reachable on one of the local networks, linuxconf will
not add a static route, for example.

So without further information, I have to consider this a
configuration problem on the remote machine.  I think I would
want to have an archive of /etc/sysconfig/static-routes and
/etc/sysconfig/network-scripts/ifcfg* in order to examine this
any further.

------- Email Received From  Jacques Gelinas <jack@solucorp.qc.ca> 03/24/99 13:15 -------


Note You need to log in before you can comment on or make changes to this bug.