Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 142436 - initscripts - ifup ppp0 hangs and never completes
Summary: initscripts - ifup ppp0 hangs and never completes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 145398 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-12-09 18:43 UTC by Steve Grubb
Modified: 2014-03-17 02:51 UTC (History)
4 users (show)

Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-01 02:12:59 UTC


Attachments (Terms of Use)
output from strace (deleted)
2004-12-09 18:50 UTC, Steve Grubb
no flags Details

Description Steve Grubb 2004-12-09 18:43:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041114 Firefox/1.0

Description of problem:
I'm running rawhide initscripts 8.00-1 and seem to have a problem.
ppp-watch never completes and ifup ppp0 just hangs:

++ WVDIALSECT=ppp0
++ MODEMNAME=Modem0
++ DEMAND=no
++ IPV6INIT=no
++ IDLETIMEOUT=600
+ '[' -r keys-ifcfg-ppp0 ']'
+ case "$TYPE" in
+ DEVICETYPE=ppp
+ '[' -z ppp ']'
+ '[' -z '' -a -n '' ']'
+ '[' -z '' ']'
+ REALDEVICE=ppp0
+ '[' ppp0 '!=' ppp0 ']'
+ ISALIAS=no
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' no '!=' yes -a Modem '!=' xDSL ']'
+ shift
+ exec /sbin/ppp-watch ppp0 ''
Failed to activate ppp0 with error 35

The failed to activate comes when I hit ctl-c. If I look in the logs I
see this:

Dec  7 08:39:46 localhost wvdial[3228]: CONNECT 45333/ARQ/V90/LAPM/V42BIS
Dec  7 08:39:46 localhost wvdial[3228]: Carrier detected.  Chatmode
finished.
Dec  7 08:39:46 localhost pppd[3216]: Serial connection established.
Dec  7 08:39:46 localhost pppd[3216]: Using interface ppp0
Dec  7 08:39:46 localhost pppd[3216]: Connect: ppp0 <--> /dev/ttyS0
Dec  7 08:39:53 localhost pppd[3216]: PAP authentication succeeded
Dec  7 08:39:55 localhost pppd[3216]: local  IP address 209.165.5.174
Dec  7 08:39:55 localhost pppd[3216]: remote IP address 209.165.107.1
Dec  7 08:39:55 localhost pppd[3216]: primary   DNS address 207.69.188.187
Dec  7 08:39:55 localhost pppd[3216]: secondary DNS address 207.69.188.186

Version-Release number of selected component (if applicable):
initscripts-8.01-1

How reproducible:
Always

Steps to Reproduce:
1. ifup ppp0

Actual Results:  See above

Additional info:

Comment 1 Steve Grubb 2004-12-09 18:50:09 UTC
Created attachment 108245 [details]
output from strace

I went into ifup-ppp and changed the exec ppp-watch to exec strace -ff -o ppp
ppp-watch. The tar file will create a directory called ifup and has all the
child processes traced.

FWIW, I backtracked to the Fedora Core 3 release of pppd (instead of rawhide)
and it still doesn't work.

Comment 2 Alexey A. Kiritchun 2005-01-11 19:03:20 UTC
I can confirm this, it works (or, really, does not work) the same way
for me, in Core 3 (ppp-2.4.2-6.4.FC3). 

Comment 3 Bill Nottingham 2005-10-03 20:13:42 UTC
I'm assuming this still doesn't work in FC4 final or the devel tree?

Comment 4 Steve Grubb 2005-10-03 20:17:15 UTC
I gave up on this and got DSL. I no longer use external modems.

Comment 5 Miloslav Trmač 2006-03-01 01:56:01 UTC
CONFIG=ifcfg-ppp0 source_config would set DEVNAME to "ifcfg-ppp0" instead of
just "ppp0".  This was probably caused by rev. 1.98 of network-functions (Oct 31
2004), and was fixed in rev. 1.105 (Feb 2 2005).




Comment 6 Bill Nottingham 2006-03-01 02:12:59 UTC
Closing; please reopen if it recurs on a current release.

Comment 7 Miloslav Trmač 2006-03-05 12:46:02 UTC
*** Bug 145398 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.