Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 142 - glib-devel-1.1.3-1 package missing glibconfig.h
Summary: glib-devel-1.1.3-1 package missing glibconfig.h
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: biff
Version: 5.2
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 613 1019 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-20 00:49 UTC by Damien, Miller
Modified: 2014-03-17 02:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-11-20 12:07:36 UTC


Attachments (Terms of Use)

Description Damien, Miller 1998-11-20 00:49:47 UTC
The glib-devel-1.1.3-1 package is missing glibconfig.h which
makes it impossible to build glib-dependant programs.

You bug-tracking systems also lacks package entries for
gtk-devel, glib and glib-devel

Comment 1 Bill Nottingham 1998-11-20 11:37:59 UTC
Um...
a) we don't ship glib-devel in 5.2 (it's in the gnome dir, but
it's not part of the distribution)
b) glibconfig is in that package...
/usr/lib/glib/include/glibconfig.h

Comment 2 Jeff Johnson 1999-02-12 18:12:59 UTC
*** Bug 613 has been marked as a duplicate of this bug. ***

in /usr/include, add a symlink to
../lib/glib/include/glibconfig.h

------- Additional Comments From dkl@redhat.com  12/31/98 15:36 -------
glibconfig.h is a system dependent header.  Therefore it lives in
/usr/lib, not /usr/include.  /usr/include is shareable across
architectures.  The correct gcc line for building glib apps just need
to include the directory that glibconfig.h lives by including
"-I/usr/lib/glib/include" on the command line.

Comment 3 Jeff Johnson 1999-02-12 18:13:59 UTC
*** Bug 1019 has been marked as a duplicate of this bug. ***

My glib.h #include glibconfig.h
but there is no glibconfig.h to be found.

Discovered this problem the first time I tried to use gcc.

/usr/include/glib.h:22 glibconfig.h: No such file or
directory

There was an undefined symbol G_GNUC_NORETURN
which I had to comment out of a source file to
compile a newer version of GIMP.


------- Additional Comments From ayn2@cornell.edu  02/02/99 01:36 -------
This looks as a duplicate of reports #142 and #613


Note You need to log in before you can comment on or make changes to this bug.