Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 141723 - [iiimx] doesn't fallback fonts when the glyphs are missing
Summary: [iiimx] doesn't fallback fonts when the glyphs are missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
: 141443 154088 (view as bug list)
Depends On:
Blocks: IIIMF Indic FC5Target 158727
TreeView+ depends on / blocked
 
Reported: 2004-12-03 10:23 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 01:12:25 UTC


Attachments (Terms of Use)
screenshot of candidate window in the hi locale (deleted)
2004-12-03 10:24 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2004-12-03 10:23:56 UTC
Description of problem: 
After the removal of roman characters from the font package, the 
candidate window is not able to display the numbers. Instead it now 
display empty square. 
 
Version-Release number of selected component (if applicable): 
ttfonts-hi-1.8-1 
im-sdk-12.1-10.EL 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.Log in as normal user into KDE 
2.start kedit 
3.Ctrl+SPACE to toggle on LE 
4.Press F6 to switch to phonetic 
5.Enter anything 
   
Actual results: 
Candidate windows display squares 
 
Expected results: 
Should not be displaying squares 
 
Additional info: 
Please confirm if this is an LE problem or fint package issue.

Comment 1 Lawrence Lim 2004-12-03 10:24:47 UTC
Created attachment 107823 [details]
screenshot of candidate window in the hi locale

Comment 2 Lawrence Lim 2004-12-03 10:37:17 UTC
In GNOME env, the display of the candidates wondow is fine.

Comment 3 Lawrence Lim 2004-12-03 11:11:11 UTC
Here is another test case.

1) start kedit
2) ctrl-space
3) qaz
4) F6
5) F6
6) a

Comment 4 Leon Ho 2004-12-06 04:58:18 UTC
I can reproduce on comment #3 for hi_IN.UTF-8. LE does not handle
glyphs rendering so it is not a LE problem. The reason seems that
because ttfonts-hi does not have roman glyphs and httx cannot able to
fallback to different fonts for the glyphs. Please confirm.


Comment 5 Lawrence Lim 2004-12-06 05:05:04 UTC
Sounds like a httx problem then. Reassigning bug to component owner.

Comment 8 Akira TAGOH 2005-04-01 11:27:45 UTC
*** Bug 141443 has been marked as a duplicate of this bug. ***

Comment 9 Akira TAGOH 2005-04-07 09:08:57 UTC
*** Bug 154088 has been marked as a duplicate of this bug. ***

Comment 10 Lawrence Lim 2005-05-16 02:16:35 UTC
Bug still exist with iiimf-12.2-3.

Another test case,
1. LANG=hi_IN.UTF-8 kedit
2. press F5 a few times

Actaul Result
the options are represented as empty squares

Comment 12 Lawrence Lim 2005-07-12 06:02:19 UTC
Moving into QA queue.

Comment 13 Akira TAGOH 2005-07-19 03:58:17 UTC
Fixed package is 12.2-7 for devel and 12.2-4.fc4.1 for FC4.


Note You need to log in before you can comment on or make changes to this bug.