Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1416447 - Installed packages mismatch
Summary: Installed packages mismatch
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiří Dostál
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
: 1075533 (view as bug list)
Depends On:
Blocks: sat560-triage sat580-low
TreeView+ depends on / blocked
 
Reported: 2017-01-25 14:12 UTC by Lukáš Hellebrandt
Modified: 2017-06-21 12:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 12:17:54 UTC


Attachments (Terms of Use)

Description Lukáš Hellebrandt 2017-01-25 14:12:26 UTC
Description of problem:
When installing, the following warning appears:
========================================================
* Installing Satellite packages.
Warning: more packages were installed by yum than expected:
	at
	atk
	avahi-libs
	cairo
	cups-libs
	ed
	fontconfig
	freetype
	gdk-pixbuf2
	gnutls
	gtk2
	hicolor-icon-theme
	jasper-libs
	libX11
	libX11-common
	libXau
	libXcomposite
	libXcursor
	libXdamage
	libXext
	libXfixes
	libXft
	libXi
	libXinerama
	libXrandr
	libXrender
	libjpeg-turbo
	libpng
	libthai
	libtiff
	libxcb
	lsof
	mailx
	man
	pango
	pixman
	redhat-rpm-config
	scl-utils
	tcl
	tcsh
	time
	unzip
	xz
	xz-lzma-compat
	zip
Warning: yum did not install the following packages:
	libXt
* Now running spacewalk-setup.
========================================================

This particular warning is for RHEL 6.8 on a Beaker machine, Sat compose from 20160120, installing against ManagedDB.
The error has also been reproduced for other scenarios including RHEL 6.9.
Package list differs for e.g. Beaker and OS machines.

This is regression against verified bug 1281691.

How reproducible:
Deterministic

Steps to Reproduce:
1. ./install.pl

Actual results:
Successful installation but warnings present

Expected results:
No warnings

Comment 1 Lukáš Hellebrandt 2017-01-25 14:32:09 UTC
These packages are different depending on the system's package configuration. Is there some only supported configuration this warning does not appear on? Do we want to check this at all, doing the job of a package manager?

Comment 2 Lukáš Hellebrandt 2017-01-25 16:06:13 UTC
Some of these packages are from Base package group that needs to be installed (and is not installed on OS systems, hence the difference). On Beaker x86_64 machines with RHEL 6.9 (with Base installed by default), the message is:

Warning: more packages were installed by yum than expected:
	mtools
	syslinux
	syslinux-nonlinux

Comment 3 Lukáš Hellebrandt 2017-01-26 10:39:57 UTC
On s390x ManageDB:

Warning: yum did not install the following packages:
	perl-Params-Validate

But:

#rpm -q perl-Params-Validate
perl-Params-Validate-0.92-3.el6.s390x

# grep perl-Params-Validate -A1 -B1 /var/log/yum.log 
Jan 26 05:18:34 Installed: satellite-repo-5.8.0.2-1.el6sat.noarch
Jan 26 05:31:36 Installed: perl-Params-Validate-0.92-3.el6.s390x
Jan 26 05:31:37 Installed: postgresql-libs-8.4.20-7.el6.s390x

Comment 4 Lukáš Hellebrandt 2017-01-26 11:52:47 UTC
s390x ExtPostgre:

Warning: more packages were installed by yum than expected:
	perl-Frontier-RPC-Client
Warning: yum did not install the following packages:
	antlr
	jakarta-commons-codec
	jakarta-commons-lang
	jakarta-oro
	jdom
	mod_perl
	objectweb-asm
	perl-BSD-Resource
	perl-Class-Singleton
	perl-DateTime
	perl-Frontier-RPC
	perl-List-MoreUtils
	perl-Params-Validate
	perl-TermReadKey
	xalan-j2

Comment 5 Radovan Drazny 2017-01-26 12:39:17 UTC
(In reply to Lukáš Hellebrandt from comment #2)
> Some of these packages are from Base package group that needs to be
> installed (and is not installed on OS systems, hence the difference). On
> Beaker x86_64 machines with RHEL 6.9 (with Base installed by default), the
> message is:
> 
> Warning: more packages were installed by yum than expected:
> 	mtools
> 	syslinux
> 	syslinux-nonlinux

Almost same for me when installing Sat 5.8 with external PostgreSQL on RHEL 6.9 (x86_64 Server). "Almost" means this addition:

Warning: yum did not install the following packages:
        ecj

Comment 6 Radovan Drazny 2017-01-26 13:42:03 UTC
Installing with --external-oracle on s390x:

Warning: yum did not install the following packages:
        antlr
        ecj
        jakarta-commons-codec
        jakarta-commons-lang
        jakarta-oro
        jdom
        objectweb-asm
        perl-Class-Singleton
        perl-DateTime
        perl-List-MoreUtils
        perl-Params-Validate
        perl-TermReadKey
        xalan-j2

Comment 10 Tomas Lestach 2017-03-06 09:55:04 UTC
*** Bug 1075533 has been marked as a duplicate of this bug. ***

Comment 11 Lukáš Hellebrandt 2017-03-20 11:57:35 UTC
Verified with Sat 5.8 compose from 2017-03-19.

Tested scenarios:
Embedded PostgreSQL
ManagedDB
External Oracle

Tested on x86_64.
s390x packages are allowed to differ according to devel.

Comment 12 Lukáš Hellebrandt 2017-03-20 13:11:29 UTC
Additionally verified on s390x ManagedDB because now there are different lists for different architectures provided.


Note You need to log in before you can comment on or make changes to this bug.